summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-03-06 23:25:22 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-03-06 23:25:22 +0000
commit41449cab6e09a1c4d740da624ad797b186c0ac7f (patch)
tree1a9ee3c16ab28420920d51459b916c68064adeb6 /dev-python/pyatspi/pyatspi-2.2.1.ebuild
parentClean up old revision. (diff)
downloadgentoo-2-41449cab6e09a1c4d740da624ad797b186c0ac7f.tar.gz
gentoo-2-41449cab6e09a1c4d740da624ad797b186c0ac7f.tar.bz2
gentoo-2-41449cab6e09a1c4d740da624ad797b186c0ac7f.zip
Clean up old revisions.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'dev-python/pyatspi/pyatspi-2.2.1.ebuild')
-rw-r--r--dev-python/pyatspi/pyatspi-2.2.1.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/dev-python/pyatspi/pyatspi-2.2.1.ebuild b/dev-python/pyatspi/pyatspi-2.2.1.ebuild
deleted file mode 100644
index 75f3aec1afaf..000000000000
--- a/dev-python/pyatspi/pyatspi-2.2.1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyatspi/pyatspi-2.2.1.ebuild,v 1.10 2012/10/17 04:29:54 tetromino Exp $
-
-EAPI="4"
-GCONF_DEBUG="no"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5 3.* *-jython *-pypy-*"
-
-inherit autotools eutils gnome2 python
-
-DESCRIPTION="Python binding to at-spi library"
-HOMEPAGE="http://live.gnome.org/Accessibility"
-
-# Note: only some of the tests are GPL-licensed, everything else is LGPL
-LICENSE="LGPL-2 GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~x86"
-IUSE="" # test
-
-# test suite is obsolete (at-spi-1.x era) and unpassable
-RESTRICT="test"
-
-COMMON_DEPEND="dev-python/dbus-python
- >=dev-python/pygobject-2.90.1:3
-"
-RDEPEND="${COMMON_DEPEND}
- >=sys-apps/dbus-1
- >=app-accessibility/at-spi2-core-${PV}[introspection]
- !<gnome-extra/at-spi-1.32.0-r1
-"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig"
-
-pkg_setup() {
- G2CONF="${G2CONF} --disable-tests"
- python_pkg_setup
-}
-
-src_prepare() {
- # Fix configure to disable tests properly, upstream bug #670823
- epatch "${FILESDIR}/${PN}-2.2.1-configure-check.patch"
-
- # remove pygtk cruft; https://bugzilla.gnome.org/show_bug.cgi?id=660826
- # requires eautoreconf
- epatch "${FILESDIR}/${PN}-2.2.0-AM_CHECK_PYMOD-pygtk.patch"
- eautoreconf
-
- gnome2_src_prepare
-
- python_clean_py-compile_files
- python_copy_sources
-}
-
-src_configure() {
- python_execute_function -s gnome2_src_configure
-}
-
-src_compile() {
- python_execute_function -s gnome2_src_compile
-}
-
-src_install() {
- python_execute_function -s gnome2_src_install
- python_clean_installation_image
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- python_mod_optimize pyatspi
-}
-
-pkg_postrm() {
- gnome2_pkg_postrm
- python_mod_cleanup pyatspi
-}