summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-05-23 05:10:44 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-05-23 05:10:44 +0000
commit69cb4c79e61a978d07b61ed8c56bd59dbf094ed1 (patch)
treedc1ad75b3bab6e8718061f6d75dc4106081eee56 /dev-python/py
parentVersion bump. (diff)
downloadgentoo-2-69cb4c79e61a978d07b61ed8c56bd59dbf094ed1.tar.gz
gentoo-2-69cb4c79e61a978d07b61ed8c56bd59dbf094ed1.tar.bz2
gentoo-2-69cb4c79e61a978d07b61ed8c56bd59dbf094ed1.zip
Bump
(Portage version: 2.2.0_alpha176/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/py')
-rw-r--r--dev-python/py/ChangeLog7
-rw-r--r--dev-python/py/py-1.4.14.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-python/py/ChangeLog b/dev-python/py/ChangeLog
index a2152187b6b8..719b2fb7552d 100644
--- a/dev-python/py/ChangeLog
+++ b/dev-python/py/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/py
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/py/ChangeLog,v 1.143 2013/05/12 18:18:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/py/ChangeLog,v 1.144 2013/05/23 05:10:44 patrick Exp $
+
+*py-1.4.14 (23 May 2013)
+
+ 23 May 2013; Patrick Lauer <patrick@gentoo.org> +py-1.4.14.ebuild:
+ Bump
12 May 2013; Mike Frysinger <vapier@gentoo.org> py-1.4.13.ebuild:
Add missing ~s390 #469242.
diff --git a/dev-python/py/py-1.4.14.ebuild b/dev-python/py/py-1.4.14.ebuild
new file mode 100644
index 000000000000..ba15d23adf01
--- /dev/null
+++ b/dev-python/py/py-1.4.14.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/py/py-1.4.14.ebuild,v 1.1 2013/05/23 05:10:44 patrick Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_8,1_9,2_0} )
+inherit distutils-r1
+
+DESCRIPTION="library with cross-python path, ini-parsing, io, code, log facilities"
+HOMEPAGE="http://pylib.readthedocs.org/ http://pypi.python.org/pypi/py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pytest-2[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+DOCS=( CHANGELOG README.txt )
+
+python_test() {
+ py.test || die "testing failed with ${EPYTHON}"
+}