summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-09-04 12:51:12 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-09-04 12:51:12 +0000
commit66ea897542ccff663010385d688ddb89a1e066ff (patch)
treee0d1cd2981f2f5eae49fd574a56e8f3968e78848 /dev-python/psutil
parentVersion bump decorator to 3.3.2. (diff)
downloadgentoo-2-66ea897542ccff663010385d688ddb89a1e066ff.tar.gz
gentoo-2-66ea897542ccff663010385d688ddb89a1e066ff.tar.bz2
gentoo-2-66ea897542ccff663010385d688ddb89a1e066ff.zip
Version bump psutil to 0.3.0.
(Portage version: 2.1.10.12/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/psutil')
-rw-r--r--dev-python/psutil/ChangeLog7
-rw-r--r--dev-python/psutil/psutil-0.3.0.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-python/psutil/ChangeLog b/dev-python/psutil/ChangeLog
index 80680609fff4..7fa843b502f5 100644
--- a/dev-python/psutil/ChangeLog
+++ b/dev-python/psutil/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/psutil
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/psutil/ChangeLog,v 1.2 2011/07/26 16:08:51 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psutil/ChangeLog,v 1.3 2011/09/04 12:51:12 djc Exp $
+
+*psutil-0.3.0 (04 Sep 2011)
+
+ 04 Sep 2011; Dirkjan Ochtman <djc@gentoo.org> +psutil-0.3.0.ebuild:
+ Version bump to 0.3.0 (bug 379427).
26 Jul 2011; Jesus Rivero <neurogeek@gentoo.org> psutil-0.2.1.ebuild:
HOMEPAGE and tests fix
diff --git a/dev-python/psutil/psutil-0.3.0.ebuild b/dev-python/psutil/psutil-0.3.0.ebuild
new file mode 100644
index 000000000000..6052736f152d
--- /dev/null
+++ b/dev-python/psutil/psutil-0.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psutil/psutil-0.3.0.ebuild,v 1.1 2011/09/04 12:51:12 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_TESTS_RESTRICTED_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Retrieve information on running processes and system utilization"
+HOMEPAGE="http://code.google.com/p/psutil/ http://pypi.python.org/pypi/psutil"
+SRC_URI="http://psutil.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# A broken test
+RESTRICT="test"
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" test/test_psutil.py
+ }
+ python_execute_function testing
+}