summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-14 19:01:05 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-14 19:01:05 +0000
commitbf71d8e5c6e6e08196c58c98b0081f378c5693c6 (patch)
tree4d7fa3aa269f15e8f67581270d0200318eaf18c1 /dev-python/promise
parentDelete older ebuild. (diff)
downloadgentoo-2-bf71d8e5c6e6e08196c58c98b0081f378c5693c6.tar.gz
gentoo-2-bf71d8e5c6e6e08196c58c98b0081f378c5693c6.tar.bz2
gentoo-2-bf71d8e5c6e6e08196c58c98b0081f378c5693c6.zip
Version bump. Fixed compatibility with Python 2.7 (bug #327215).
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/promise')
-rw-r--r--dev-python/promise/ChangeLog10
-rw-r--r--dev-python/promise/promise-0.2.2.ebuild30
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-python/promise/ChangeLog b/dev-python/promise/ChangeLog
index 80fc8806b235..d7e29f07e72b 100644
--- a/dev-python/promise/ChangeLog
+++ b/dev-python/promise/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/promise
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/promise/ChangeLog,v 1.3 2010/07/06 21:37:41 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/promise/ChangeLog,v 1.4 2011/04/14 19:01:05 arfrever Exp $
+
+*promise-0.2.2 (14 Apr 2011)
+
+ 14 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +promise-0.2.2.ebuild:
+ Version bump. Fixed compatibility with Python 2.7 (bug #327215).
06 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
promise-0.2.1.ebuild:
diff --git a/dev-python/promise/promise-0.2.2.ebuild b/dev-python/promise/promise-0.2.2.ebuild
new file mode 100644
index 000000000000..0ed4456eef04
--- /dev/null
+++ b/dev-python/promise/promise-0.2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/promise/promise-0.2.2.ebuild,v 1.1 2011/04/14 19:01:05 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Bytecode optimisation using staticness assertions."
+HOMEPAGE="https://github.com/rfk/promise/ http://pypi.python.org/pypi/promise"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PF}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+DOCS="ChangeLog.txt README.txt"
+
+src_test() {
+ # Timing tests fail.
+ PROMISE_SKIP_TIMING_TESTS="1" distutils_src_test
+}