summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-03-19 17:45:32 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-03-19 17:45:32 +0000
commitc7dec775391a9b6f9f26e81908257937261860f8 (patch)
treeb1d3fab760d6daccfe70f4176e61ab699e297c57 /dev-python/pmw
parent*** empty log message *** (diff)
downloadgentoo-2-c7dec775391a9b6f9f26e81908257937261860f8.tar.gz
gentoo-2-c7dec775391a9b6f9f26e81908257937261860f8.tar.bz2
gentoo-2-c7dec775391a9b6f9f26e81908257937261860f8.zip
Initial version of Pmw toolkit package.
Pmw is a toolkit for building high-level compound widgets in Python using the Tkinter module.
Diffstat (limited to 'dev-python/pmw')
-rw-r--r--dev-python/pmw/ChangeLog9
-rw-r--r--dev-python/pmw/files/digest-pmw-0.8.51
-rw-r--r--dev-python/pmw/pmw-0.8.5.ebuild50
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/pmw/ChangeLog b/dev-python/pmw/ChangeLog
new file mode 100644
index 000000000000..cf2b6fb1c75e
--- /dev/null
+++ b/dev-python/pmw/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/pmw
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/ChangeLog,v 1.1 2002/03/19 17:45:32 agenkin Exp $
+
+*pmw-0.8.5 (<Mar 19, 2002>)
+
+ 19 Mar 2002; Arcady Genkin <agenkin@thpoon.com> pmw-0.8.5.ebuild :
+
+ Initial version of the package. \ No newline at end of file
diff --git a/dev-python/pmw/files/digest-pmw-0.8.5 b/dev-python/pmw/files/digest-pmw-0.8.5
new file mode 100644
index 000000000000..2773cc24ad4b
--- /dev/null
+++ b/dev-python/pmw/files/digest-pmw-0.8.5
@@ -0,0 +1 @@
+MD5 1f6c205099c719102633800843fff51a Pmw.0.8.5.tar.gz 340469
diff --git a/dev-python/pmw/pmw-0.8.5.ebuild b/dev-python/pmw/pmw-0.8.5.ebuild
new file mode 100644
index 000000000000..5716dd2246d5
--- /dev/null
+++ b/dev-python/pmw/pmw-0.8.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Arcady Genkin <agenkin@thpoon.com>
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/pmw-0.8.5.ebuild,v 1.1 2002/03/19 17:45:32 agenkin Exp $
+
+DESCRIPTION="A toolkit for building high-level compound widgets in Python using the Tkinter module."
+HOMEPAGE="http://pmw.sourceforge.net/"
+
+DEPEND=">=dev-lang/python-2.1"
+
+SRC_URI="http://prdownloads.sourceforge.net/pmw/Pmw.${PV}.tar.gz"
+S="${WORKDIR}"/Pmw
+
+src_compile() {
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ die "You need to recompile Python with Tkinter support"
+ fi
+ python -c 'import compileall; compileall.compile_dir(".",force=1)'
+}
+
+src_install () {
+ # Figures out the destination directory, based on Python's version
+ # installed.
+ local pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
+ local pmwdir="/usr/lib/python${pv}/site-packages/Pmw"
+
+ local dir
+ for dir in `find . -type d`
+ do
+ # Skip the doc directory
+ if [ `basename "${dir}"` = "doc" ]
+ then
+ continue
+ fi
+ insinto "${pmwdir}/${dir}"
+ cd "${dir}"
+ # Install all regular files in this dir
+ local file
+ for file in *
+ do
+ [ -f "${file}" ] && doins "${file}"
+ done
+ cd "${S}"
+ done
+
+ dodoc README
+ local docdir=`find . -type d -name doc`
+ dohtml -a html,gif,py "${docdir}"/*
+}