summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-18 18:37:01 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-18 18:37:01 +0000
commit6209aa4bd25c2a2069fcd63a722501358e604f1d (patch)
treea7d558386b32a01b1b9fbceeec48ce8251233b2e /dev-python/ply
parentDelete older ebuild. (diff)
downloadgentoo-2-6209aa4bd25c2a2069fcd63a722501358e604f1d.tar.gz
gentoo-2-6209aa4bd25c2a2069fcd63a722501358e604f1d.tar.bz2
gentoo-2-6209aa4bd25c2a2069fcd63a722501358e604f1d.zip
Version bump. Fixed support for Python 3 in ply.cpp (bug #343641). Fixed tests with Python 3.2 (bug #343753).
(Portage version: 2.2.0_alpha24_p9/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/ply')
-rw-r--r--dev-python/ply/ChangeLog11
-rw-r--r--dev-python/ply/ply-3.4.ebuild56
2 files changed, 65 insertions, 2 deletions
diff --git a/dev-python/ply/ChangeLog b/dev-python/ply/ChangeLog
index b38b0ce55709..6bb9ff721bd7 100644
--- a/dev-python/ply/ChangeLog
+++ b/dev-python/ply/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/ply
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ply/ChangeLog,v 1.13 2010/08/16 16:37:11 djc Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ply/ChangeLog,v 1.14 2011/02/18 18:37:01 arfrever Exp $
+
+*ply-3.4 (18 Feb 2011)
+
+ 18 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -ply-3.3.ebuild, +ply-3.4.ebuild:
+ Version bump. Fixed support for Python 3 in ply.cpp (bug #343641). Fixed
+ tests with Python 3.2 (bug #343753).
16 Aug 2010; Dirkjan Ochtman <djc@gentoo.org> ply-3.3.ebuild:
Update license (see homepage; bug 333025).
diff --git a/dev-python/ply/ply-3.4.ebuild b/dev-python/ply/ply-3.4.ebuild
new file mode 100644
index 000000000000..e8b427d5deb3
--- /dev/null
+++ b/dev-python/ply/ply-3.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ply/ply-3.4.ebuild,v 1.1 2011/02/18 18:37:01 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Python Lex-Yacc library"
+HOMEPAGE="http://www.dabeaz.com/ply/ http://pypi.python.org/pypi/ply"
+SRC_URI="http://www.dabeaz.com/ply/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+DOCS="ANNOUNCE CHANGES README TODO"
+
+src_test() {
+ python_enable_pyc
+
+ cd test
+
+ testing() {
+ local exit_status="0" test
+
+ for test in testlex.py testyacc.py; do
+ einfo "Running ${test}..."
+ if ! "$(PYTHON)" testlex.py; then
+ ewarn "${test} failed with $(python_get_implementation) $(python_get_version)"
+ exit_status="1"
+ fi
+ done
+
+ return "${exit_status}"
+ }
+ python_execute_function testing
+
+ python_disable_pyc
+}
+
+src_install() {
+ distutils_src_install
+
+ dohtml doc/* || die "dohtml failed"
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r example/* || die "doins failed"
+ fi
+}