summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-07-01 06:29:47 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-07-01 06:29:47 +0000
commit1cea6c5f34a27f37870b1a95aab1e1bf20aaca9c (patch)
tree67dfb01f81dbd7f9cd1b16f9fae86408f10160b4 /dev-python/ply
parentInitial import. (diff)
downloadgentoo-2-1cea6c5f34a27f37870b1a95aab1e1bf20aaca9c.tar.gz
gentoo-2-1cea6c5f34a27f37870b1a95aab1e1bf20aaca9c.tar.bz2
gentoo-2-1cea6c5f34a27f37870b1a95aab1e1bf20aaca9c.zip
Bump to 2.5. Small fixes to remove deprecation warnings. Tests fail because of a path mismatch although the results would be valid.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/ply')
-rw-r--r--dev-python/ply/ChangeLog10
-rw-r--r--dev-python/ply/ply-2.5.ebuild36
2 files changed, 44 insertions, 2 deletions
diff --git a/dev-python/ply/ChangeLog b/dev-python/ply/ChangeLog
index dbb260570d45..2c7dcb45fcc4 100644
--- a/dev-python/ply/ChangeLog
+++ b/dev-python/ply/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/ply
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ply/ChangeLog,v 1.9 2007/07/03 10:39:28 lucass Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ply/ChangeLog,v 1.10 2009/07/01 06:29:47 patrick Exp $
+
+*ply-2.5 (01 Jul 2009)
+
+ 01 Jul 2009; Patrick Lauer <patrick@gentoo.org> +ply-2.5.ebuild:
+ Bump to 2.5. Small fixes to remove deprecation warnings. Tests fail
+ because of a path mismatch although the results would be valid.
03 Jul 2007; Lukasz Strzygowski <lucass@gentoo.org> -ply-2.2.ebuild:
Dropped old version.
diff --git a/dev-python/ply/ply-2.5.ebuild b/dev-python/ply/ply-2.5.ebuild
new file mode 100644
index 000000000000..dd65910dd61a
--- /dev/null
+++ b/dev-python/ply/ply-2.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ply/ply-2.5.ebuild,v 1.1 2009/07/01 06:29:47 patrick Exp $
+
+EAPI="2"
+
+inherit distutils
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+
+DESCRIPTION="Python Lex-Yacc library"
+SRC_URI="http://www.dabeaz.com/ply/${P}.tar.gz"
+HOMEPAGE="http://www.dabeaz.com/ply/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="examples"
+
+src_prepare() {
+ sed -i -e 's/md5,/hashlib,/' ply/yacc.py
+ sed -i -e 's/md5.new/hashlib.md5/' ply/yacc.py
+}
+
+src_install() {
+ DOCS="ANNOUNCE CHANGES"
+ distutils_src_install
+ dohtml doc/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r example
+ fi
+}
+
+src_test() {
+ cd test
+ "${python}" rununit.py || die "test failed"
+}