summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-03-09 20:41:11 +0000
committerTim Harder <radhermit@gentoo.org>2013-03-09 20:41:11 +0000
commita308f604a962d68d62ef44e2f36843c40d3ed41e (patch)
treee3245b66304f4adba2625205e9cec052b8986184 /dev-python/pip
parentAdd net-misc/ssstp-client, thanks to slepnoga. Bug #446780. (diff)
downloadgentoo-2-a308f604a962d68d62ef44e2f36843c40d3ed41e.tar.gz
gentoo-2-a308f604a962d68d62ef44e2f36843c40d3ed41e.tar.bz2
gentoo-2-a308f604a962d68d62ef44e2f36843c40d3ed41e.zip
Version bump, migrate to distutils-r1.
(Portage version: 2.2.0_alpha165/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/ChangeLog10
-rw-r--r--dev-python/pip/files/pip-1.3.1-unversioned.patch11
-rw-r--r--dev-python/pip/pip-1.3.1.ebuild44
3 files changed, 63 insertions, 2 deletions
diff --git a/dev-python/pip/ChangeLog b/dev-python/pip/ChangeLog
index 8b84d81f716a..b4c6cccf0d6f 100644
--- a/dev-python/pip/ChangeLog
+++ b/dev-python/pip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pip
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.14 2012/11/11 11:32:02 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.15 2013/03/09 20:41:11 radhermit Exp $
+
+*pip-1.3.1 (09 Mar 2013)
+
+ 09 Mar 2013; Tim Harder <radhermit@gentoo.org> +pip-1.3.1.ebuild,
+ +files/pip-1.3.1-unversioned.patch:
+ Version bump, migrate to distutils-r1.
11 Nov 2012; Tim Harder <radhermit@gentoo.org> -pip-1.0.2.ebuild:
Remove old.
diff --git a/dev-python/pip/files/pip-1.3.1-unversioned.patch b/dev-python/pip/files/pip-1.3.1-unversioned.patch
new file mode 100644
index 000000000000..25d549361334
--- /dev/null
+++ b/dev-python/pip/files/pip-1.3.1-unversioned.patch
@@ -0,0 +1,11 @@
+--- pip-1.3.1/setup.py
++++ pip-1.3.1/setup.py
+@@ -51,7 +51,7 @@
+ license='MIT',
+ packages=['pip', 'pip.commands', 'pip.vcs', 'pip.backwardcompat'],
+ package_data={'pip': ['*.pem']},
+- entry_points=dict(console_scripts=['pip=pip:main', 'pip-%s=pip:main' % sys.version[:3]]),
++ entry_points=dict(console_scripts=['pip=pip:main']),
+ test_suite='nose.collector',
+ tests_require=tests_require,
+ zip_safe=False,
diff --git a/dev-python/pip/pip-1.3.1.ebuild b/dev-python/pip/pip-1.3.1.ebuild
new file mode 100644
index 000000000000..c31871d7721f
--- /dev/null
+++ b/dev-python/pip/pip-1.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/pip-1.3.1.ebuild,v 1.1 2013/03/09 20:41:11 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Installs python packages -- replacement for easy_install"
+HOMEPAGE="http://www.pip-installer.org/ http://pypi.python.org/pypi/pip/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="zsh-completion"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+# required test data isn't bundled with the tarball
+RESTRICT="test"
+
+python_prepare_all() {
+ epatch "${FILESDIR}"/${P}-unversioned.patch
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS.txt docs/*.txt )
+ distutils-r1_python_install_all
+
+ COMPLETION="${T}"/completion.tmp
+
+ ${EPYTHON} pip/runner.py completion --bash > "${COMPLETION}" || die
+ newbashcomp "${COMPLETION}" ${PN}
+
+ if use zsh-completion ; then
+ ${EPYTHON} pip/runner.py completion --zsh > "${COMPLETION}" || die
+ insinto /usr/share/zsh/site-functions
+ newins "${COMPLETION}" _pip
+ fi
+}