summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-09-06 19:44:08 +0000
committerTim Harder <radhermit@gentoo.org>2012-09-06 19:44:08 +0000
commit757fdfa916fdeae50cb1883523f4ba82bf464e32 (patch)
treecc1c6b7ffb5b34fd061089b757ad4e56c57312a0 /dev-python/pip
parentDrop ia64 hack since we no longer care about <gcc-4.1 versions. (diff)
downloadgentoo-2-757fdfa916fdeae50cb1883523f4ba82bf464e32.tar.gz
gentoo-2-757fdfa916fdeae50cb1883523f4ba82bf464e32.tar.bz2
gentoo-2-757fdfa916fdeae50cb1883523f4ba82bf464e32.zip
Version bump.
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/ChangeLog7
-rw-r--r--dev-python/pip/pip-1.2.1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/pip/ChangeLog b/dev-python/pip/ChangeLog
index 390d8ae3a03f..a812a8915af9 100644
--- a/dev-python/pip/ChangeLog
+++ b/dev-python/pip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pip
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.9 2012/09/02 02:49:50 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.10 2012/09/06 19:44:08 radhermit Exp $
+
+*pip-1.2.1 (06 Sep 2012)
+
+ 06 Sep 2012; Tim Harder <radhermit@gentoo.org> +pip-1.2.1.ebuild:
+ Version bump.
*pip-1.2 (02 Sep 2012)
diff --git a/dev-python/pip/pip-1.2.1.ebuild b/dev-python/pip/pip-1.2.1.ebuild
new file mode 100644
index 000000000000..ad090a665285
--- /dev/null
+++ b/dev-python/pip/pip-1.2.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/pip-1.2.1.ebuild,v 1.1 2012/09/06 19:44:08 radhermit Exp $
+
+EAPI="4"
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit bash-completion-r1 distutils eutils
+
+DESCRIPTION="Installs python packages -- replacement for easy_install"
+HOMEPAGE="http://www.pip-installer.org/ http://pypi.python.org/pypi/pip/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="zsh-completion"
+
+RDEPEND="dev-python/setuptools"
+DEPEND="${RDEPEND}"
+
+# Tests require a couple libraries not yet in the tree, aren't bundled with
+# the default tarball from pypi, and have a couple failures anyway
+RESTRICT="test"
+
+DOCS="AUTHORS.txt docs/*.txt"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.1-unversioned.patch
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+ COMPLETION="${T}/completion.tmp"
+
+ "$(PYTHON -f)" pip/runner.py completion --bash > "${COMPLETION}" || die
+ newbashcomp "${COMPLETION}" ${PN}
+
+ if use zsh-completion ; then
+ "$(PYTHON -f)" pip/runner.py completion --zsh > "${COMPLETION}" || die
+ insinto /usr/share/zsh/site-functions
+ newins "${COMPLETION}" _pip
+ fi
+}