summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-02-07 02:48:57 +0000
committerTim Harder <radhermit@gentoo.org>2015-02-07 02:48:57 +0000
commit5904b41bc311fed4772fc991956045879f2de441 (patch)
tree7cabe7416623d10fa0ac3377d8752cd8a80cf242 /dev-python/pip
parentVersion bump. (diff)
downloadgentoo-2-5904b41bc311fed4772fc991956045879f2de441.tar.gz
gentoo-2-5904b41bc311fed4772fc991956045879f2de441.tar.bz2
gentoo-2-5904b41bc311fed4772fc991956045879f2de441.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/ChangeLog7
-rw-r--r--dev-python/pip/pip-6.0.8.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-python/pip/ChangeLog b/dev-python/pip/ChangeLog
index 46a0ae215697..ac9e8fa6fd2b 100644
--- a/dev-python/pip/ChangeLog
+++ b/dev-python/pip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pip
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.54 2015/01/31 08:19:19 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.55 2015/02/07 02:48:57 radhermit Exp $
+
+*pip-6.0.8 (07 Feb 2015)
+
+ 07 Feb 2015; Tim Harder <radhermit@gentoo.org> +pip-6.0.8.ebuild:
+ Version bump.
*pip-6.0.7 (31 Jan 2015)
diff --git a/dev-python/pip/pip-6.0.8.ebuild b/dev-python/pip/pip-6.0.8.ebuild
new file mode 100644
index 000000000000..8a856fb22b1f
--- /dev/null
+++ b/dev-python/pip/pip-6.0.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/pip-6.0.8.ebuild,v 1.1 2015/02/07 02:48:57 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Installs python packages -- replacement for easy_install"
+HOMEPAGE="http://www.pip-installer.org/ http://pypi.python.org/pypi/pip/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+# required test data isn't bundled with the tarball
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-6.0.2-disable-version-check.patch )
+
+python_install_all() {
+ local DOCS=( AUTHORS.txt docs/*.rst )
+ distutils-r1_python_install_all
+
+ COMPLETION="${T}"/completion.tmp
+
+ ${EPYTHON} pip/__init__.py completion --bash > "${COMPLETION}" || die
+ newbashcomp "${COMPLETION}" ${PN}
+
+ ${EPYTHON} pip/__init__.py completion --zsh > "${COMPLETION}" || die
+ insinto /usr/share/zsh/site-functions
+ newins "${COMPLETION}" _pip
+}