summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-11-11 11:32:05 +0000
committerTim Harder <radhermit@gentoo.org>2012-11-11 11:32:05 +0000
commit31782efad0e293df12e715864413bc0dffe0d795 (patch)
treece1ddace3ff4a797642cabd93f52a95f8c03e01b /dev-python/pip
parentAdd missing toolchain-funcs inherit (diff)
downloadgentoo-2-31782efad0e293df12e715864413bc0dffe0d795.tar.gz
gentoo-2-31782efad0e293df12e715864413bc0dffe0d795.tar.bz2
gentoo-2-31782efad0e293df12e715864413bc0dffe0d795.zip
Remove old.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/ChangeLog5
-rw-r--r--dev-python/pip/pip-1.0.2.ebuild47
2 files changed, 4 insertions, 48 deletions
diff --git a/dev-python/pip/ChangeLog b/dev-python/pip/ChangeLog
index 9d43a49b3612..8b84d81f716a 100644
--- a/dev-python/pip/ChangeLog
+++ b/dev-python/pip/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pip
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.13 2012/10/30 17:03:46 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.14 2012/11/11 11:32:02 radhermit Exp $
+
+ 11 Nov 2012; Tim Harder <radhermit@gentoo.org> -pip-1.0.2.ebuild:
+ Remove old.
30 Oct 2012; Agostino Sarubbo <ago@gentoo.org> pip-1.2.1.ebuild:
Stable for amd64, wrt bug #439720
diff --git a/dev-python/pip/pip-1.0.2.ebuild b/dev-python/pip/pip-1.0.2.ebuild
deleted file mode 100644
index 377def454192..000000000000
--- a/dev-python/pip/pip-1.0.2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/pip-1.0.2.ebuild,v 1.4 2012/02/24 15:15:50 phajdan.jr Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit bash-completion-r1 distutils eutils
-
-DESCRIPTION="Installs python packages -- replacement for easy_install"
-HOMEPAGE="http://www.pip-installer.org/ http://pypi.python.org/pypi/pip/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="amd64 x86"
-SLOT="0"
-IUSE="zsh-completion"
-
-RDEPEND="dev-python/setuptools"
-DEPEND="${RDEPEND}"
-
-# Tests require a couple libraries not yet in the tree, aren't bundled with
-# the default tarball from pypi, and have a couple failures anyway
-RESTRICT="test"
-
-DOCS="AUTHORS.txt docs/configuration.txt docs/how-to-contribute.txt
- docs/index.txt docs/news.txt docs/requirement-format.txt"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.0.1-unversioned.patch
- distutils_src_prepare
-}
-
-src_install() {
- distutils_src_install
- COMPLETION="${T}/completion.tmp"
-
- "$(PYTHON -f)" pip/runner.py completion --bash > "${COMPLETION}" || die
- newbashcomp "${COMPLETION}" ${PN}
-
- if use zsh-completion ; then
- "$(PYTHON -f)" pip/runner.py completion --zsh > "${COMPLETION}" || die
- insinto /usr/share/zsh/site-functions
- newins "${COMPLETION}" _pip || die
- fi
-}