summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-01-22 08:22:00 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-01-22 08:22:00 +0000
commit7aa71fb0aac36dfef4dfa7c2429e0a00f6ce1502 (patch)
tree8581d8cb220f3a69444d567ffbc138409500bef2 /dev-python/pep8
parentBump (diff)
downloadgentoo-2-7aa71fb0aac36dfef4dfa7c2429e0a00f6ce1502.tar.gz
gentoo-2-7aa71fb0aac36dfef4dfa7c2429e0a00f6ce1502.tar.bz2
gentoo-2-7aa71fb0aac36dfef4dfa7c2429e0a00f6ce1502.zip
Bump
(Portage version: 2.2.0_alpha159/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/pep8')
-rw-r--r--dev-python/pep8/ChangeLog9
-rw-r--r--dev-python/pep8/pep8-1.4.1.ebuild27
2 files changed, 34 insertions, 2 deletions
diff --git a/dev-python/pep8/ChangeLog b/dev-python/pep8/ChangeLog
index eb6a2770c924..36876eba5de9 100644
--- a/dev-python/pep8/ChangeLog
+++ b/dev-python/pep8/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pep8
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pep8/ChangeLog,v 1.12 2012/12/23 09:54:01 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pep8/ChangeLog,v 1.13 2013/01/22 08:22:00 patrick Exp $
+
+*pep8-1.4.1 (22 Jan 2013)
+
+ 22 Jan 2013; Patrick Lauer <patrick@gentoo.org> +pep8-1.4.1.ebuild:
+ Bump
*pep8-1.4 (23 Dec 2012)
diff --git a/dev-python/pep8/pep8-1.4.1.ebuild b/dev-python/pep8/pep8-1.4.1.ebuild
new file mode 100644
index 000000000000..ef82a1c7130c
--- /dev/null
+++ b/dev-python/pep8/pep8-1.4.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pep8/pep8-1.4.1.ebuild,v 1.1 2013/01/22 08:22:00 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python style guide checker"
+HOMEPAGE="http://github.com/jcrocholl/pep8 http://pypi.python.org/pypi/pep8"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGES.txt )
+
+python_test() {
+ PYTHONPATH="${S}" "${PYTHON}" pep8.py -v --testsuite=testsuite || die
+ PYTHONPATH="${S}" "${PYTHON}" pep8.py --doctest -v || die
+}