summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-03-26 07:00:56 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-03-26 07:00:56 +0000
commit5208492f2becfc9171e2c81f23194d2979bc12d6 (patch)
treeef405343fc6de3d025ef15e0f00960e23b4bc34f /dev-python/peewee
parenttypo (diff)
downloadgentoo-2-5208492f2becfc9171e2c81f23194d2979bc12d6.tar.gz
gentoo-2-5208492f2becfc9171e2c81f23194d2979bc12d6.tar.bz2
gentoo-2-5208492f2becfc9171e2c81f23194d2979bc12d6.zip
Bump
(Portage version: 2.2.18/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/peewee')
-rw-r--r--dev-python/peewee/ChangeLog7
-rw-r--r--dev-python/peewee/peewee-2.5.0.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/peewee/ChangeLog b/dev-python/peewee/ChangeLog
index 88dcd7c0ddc9..707f1e53eed9 100644
--- a/dev-python/peewee/ChangeLog
+++ b/dev-python/peewee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/peewee
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/ChangeLog,v 1.26 2015/02/12 07:56:59 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/ChangeLog,v 1.27 2015/03/26 07:00:56 patrick Exp $
+
+*peewee-2.5.0 (26 Mar 2015)
+
+ 26 Mar 2015; Patrick Lauer <patrick@gentoo.org> +peewee-2.5.0.ebuild:
+ Bump
*peewee-2.4.7 (12 Feb 2015)
diff --git a/dev-python/peewee/peewee-2.5.0.ebuild b/dev-python/peewee/peewee-2.5.0.ebuild
new file mode 100644
index 000000000000..010537b2a6f2
--- /dev/null
+++ b/dev-python/peewee/peewee-2.5.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/peewee-2.5.0.ebuild,v 1.1 2015/03/26 07:00:56 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Small python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/apsw[${PYTHON_USEDEP}]
+ dev-python/psycopg[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ )"
+# Req'd to ensure a unique tmp.db for each python impl running the testsuite.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" ./runtests.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}