summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-06-12 08:32:26 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-06-12 08:32:26 +0000
commit984dd1936c11b416d01e4689c4cf05db56fe13b9 (patch)
treea94be7d355863de33b37da4c39f6c860635ad9f6 /dev-python/pbr
parentAdd py34 (diff)
downloadgentoo-2-984dd1936c11b416d01e4689c4cf05db56fe13b9.tar.gz
gentoo-2-984dd1936c11b416d01e4689c4cf05db56fe13b9.tar.bz2
gentoo-2-984dd1936c11b416d01e4689c4cf05db56fe13b9.zip
Bump, relax test deps, add py34
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/pbr')
-rw-r--r--dev-python/pbr/ChangeLog7
-rw-r--r--dev-python/pbr/pbr-0.8.2.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-python/pbr/ChangeLog b/dev-python/pbr/ChangeLog
index 1b51945b49b7..4354dac1701f 100644
--- a/dev-python/pbr/ChangeLog
+++ b/dev-python/pbr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pbr
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pbr/ChangeLog,v 1.17 2014/06/08 09:53:20 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pbr/ChangeLog,v 1.18 2014/06/12 08:32:26 patrick Exp $
+
+*pbr-0.8.2 (12 Jun 2014)
+
+ 12 Jun 2014; Patrick Lauer <patrick@gentoo.org> +pbr-0.8.2.ebuild:
+ Bump, relax test deps, add py34
08 Jun 2014; Akinori Hattori <hattya@gentoo.org> pbr-0.8.0.ebuild:
keyword ~ia64 wrt bug #508282
diff --git a/dev-python/pbr/pbr-0.8.2.ebuild b/dev-python/pbr/pbr-0.8.2.ebuild
new file mode 100644
index 000000000000..9aa12b54388f
--- /dev/null
+++ b/dev-python/pbr/pbr-0.8.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pbr/pbr-0.8.2.ebuild,v 1.1 2014/06/12 08:32:26 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="PBR is a library that injects some useful and sensible default
+behaviors into your setuptools run."
+HOMEPAGE="https://github.com/openstack-dev/pbr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/flake8-2.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testresources-0.2.4[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}] )"
+RDEPEND=">dev-python/pip-1.4[${PYTHON_USEDEP}]"
+
+# Requ'd for testsuite
+DISTUTILS_IN_SOURCE_BUILD=1
+# You can do this in about 3 different ways; throw it in a src_test() and prepend it to a
+# distutils-r1_src_test or os it a distutils-r1_python_test, but really it makes for a HUGE 'meh'
+
+# This normally actually belongs here.
+python_prepare_all() {
+ # This test passes when run within the source and doesn't represent a failure, but rather
+ # a gentoo sandbox constraint
+ sed -e s':test_console_script_develop:_&:' -i pbr/tests/test_core.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ testr init
+ testr run || die "Testsuite failed under ${EPYTHON}"
+ flake8 "${PN}"/tests || die "Run over tests folder by flake8 drew error"
+}