summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-02-08 02:04:49 +0000
committerIan Delaney <idella4@gentoo.org>2015-02-08 02:04:49 +0000
commit4ec8e549eb7e7415d9bc8d684022692f469a0027 (patch)
tree15092a546c02221021acef408aa8ce66aa360d64 /dev-python/path-py
parentremoving the old and jankey (diff)
downloadgentoo-2-4ec8e549eb7e7415d9bc8d684022692f469a0027.tar.gz
gentoo-2-4ec8e549eb7e7415d9bc8d684022692f469a0027.tar.bz2
gentoo-2-4ec8e549eb7e7415d9bc8d684022692f469a0027.zip
bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/path-py')
-rw-r--r--dev-python/path-py/ChangeLog9
-rw-r--r--dev-python/path-py/path-py-7.2.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-python/path-py/ChangeLog b/dev-python/path-py/ChangeLog
index 19c5eb9e8eb8..0c45f0ca1fd1 100644
--- a/dev-python/path-py/ChangeLog
+++ b/dev-python/path-py/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/path-py
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/path-py/ChangeLog,v 1.5 2014/12/11 01:41:58 floppym Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/path-py/ChangeLog,v 1.6 2015/02/08 02:04:49 idella4 Exp $
+
+*path-py-7.2 (08 Feb 2015)
+
+ 08 Feb 2015; Ian Delaney <idella4@gentoo.org> +path-py-7.2.ebuild:
+ bump
11 Dec 2014; Mike Gilbert <floppym@gentoo.org> -path-py-6.0.ebuild,
path-py-7.0.ebuild:
diff --git a/dev-python/path-py/path-py-7.2.ebuild b/dev-python/path-py/path-py-7.2.ebuild
new file mode 100644
index 000000000000..40931951b7f3
--- /dev/null
+++ b/dev-python/path-py/path-py-7.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/path-py/path-py-7.2.ebuild,v 1.1 2015/02/08 02:04:49 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_P="path.py-${PV}"
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="http://pythonhosted.org/path.py https://pypi.python.org/pypi/path.py https://github.com/jaraco/path.py"
+SRC_URI="mirror://pypi/p/path.py/${MY_P}.zip"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ py.test || die "Testing failed with ${EPYTHON}"
+}