summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-10-21 09:24:19 +0000
committerIan Delaney <idella4@gentoo.org>2014-10-21 09:24:19 +0000
commit4668ca0d10fac858ca48b62a12c9816541d0945f (patch)
tree347bb469f2ab27a01420eae62b7eae058bf99689 /dev-python/path-py
parentAdd slot operator to Perl dependency (diff)
downloadgentoo-2-4668ca0d10fac858ca48b62a12c9816541d0945f.tar.gz
gentoo-2-4668ca0d10fac858ca48b62a12c9816541d0945f.tar.bz2
gentoo-2-4668ca0d10fac858ca48b62a12c9816541d0945f.zip
bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/path-py')
-rw-r--r--dev-python/path-py/ChangeLog7
-rw-r--r--dev-python/path-py/path-py-7.0.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/path-py/ChangeLog b/dev-python/path-py/ChangeLog
index b8177bb7aaca..899b2ec970cd 100644
--- a/dev-python/path-py/ChangeLog
+++ b/dev-python/path-py/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/path-py
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/path-py/ChangeLog,v 1.1 2014/09/27 16:11:32 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/path-py/ChangeLog,v 1.2 2014/10/21 09:24:19 idella4 Exp $
+
+*path-py-7.0 (21 Oct 2014)
+
+ 21 Oct 2014; Ian Delaney <idella4@gentoo.org> +path-py-7.0.ebuild:
+ bump
*path-py-6.0 (27 Sep 2014)
diff --git a/dev-python/path-py/path-py-7.0.ebuild b/dev-python/path-py/path-py-7.0.ebuild
new file mode 100644
index 000000000000..a2dc2e215bfd
--- /dev/null
+++ b/dev-python/path-py/path-py-7.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/path-py/path-py-7.0.ebuild,v 1.1 2014/10/21 09:24:19 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="http://github.com/jaraco/path.py"
+MY_P="path.py-${PV}"
+SRC_URI="mirror://pypi/p/path.py/${MY_P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Testing failed with ${EPYTHON}"
+}