summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-27 22:59:32 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-27 22:59:32 +0000
commit9b7ba6ce92ffb2842fcfbf6bbdc5826a32843861 (patch)
tree7d49460093a3c41ee50653c50a49e89fff44337c /dev-python/pastescript
parentx86 stable, bug 322791 (diff)
downloadgentoo-2-9b7ba6ce92ffb2842fcfbf6bbdc5826a32843861.tar.gz
gentoo-2-9b7ba6ce92ffb2842fcfbf6bbdc5826a32843861.tar.bz2
gentoo-2-9b7ba6ce92ffb2842fcfbf6bbdc5826a32843861.zip
Fix building with USE="doc".
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pastescript')
-rw-r--r--dev-python/pastescript/ChangeLog8
-rw-r--r--dev-python/pastescript/pastescript-1.7.3.ebuild34
2 files changed, 23 insertions, 19 deletions
diff --git a/dev-python/pastescript/ChangeLog b/dev-python/pastescript/ChangeLog
index 104b015e9374..1857d1cba174 100644
--- a/dev-python/pastescript/ChangeLog
+++ b/dev-python/pastescript/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pastescript
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pastescript/ChangeLog,v 1.8 2009/10/11 08:28:57 grobian Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pastescript/ChangeLog,v 1.9 2010/06/27 22:59:32 arfrever Exp $
+
+ 27 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pastescript-1.7.3.ebuild:
+ Fix building with USE="doc".
11 Oct 2009; Fabian Groffen <grobian@gentoo.org> pastescript-1.7.3.ebuild:
Merge from Prefix
diff --git a/dev-python/pastescript/pastescript-1.7.3.ebuild b/dev-python/pastescript/pastescript-1.7.3.ebuild
index e3a85c6477fc..d832a5703f8c 100644
--- a/dev-python/pastescript/pastescript-1.7.3.ebuild
+++ b/dev-python/pastescript/pastescript-1.7.3.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pastescript/pastescript-1.7.3.ebuild,v 1.4 2010/02/06 15:40:07 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pastescript/pastescript-1.7.3.ebuild,v 1.5 2010/06/27 22:59:32 arfrever Exp $
-EAPI="2"
+EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
inherit distutils
@@ -19,39 +21,37 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
IUSE="doc"
-#IUSE="doc test"
-RDEPEND="dev-python/paste
+RDEPEND=">=dev-python/paste-1.3
dev-python/pastedeploy
dev-python/cheetah"
DEPEND="${RDEPEND}
dev-python/setuptools
- doc? ( dev-python/buildutils dev-python/pygments dev-python/pudge )"
-# test? ( dev-python/nose )
-RESTRICT_PYTHON_ABIS="3.*"
+ doc? ( dev-python/pygments dev-python/sphinx )"
# Tests are broken.
RESTRICT="test"
S="${WORKDIR}/${MY_P}"
+
PYTHON_MODNAME="paste/script"
src_compile() {
distutils_src_compile
+
if use doc; then
- einfo "Generating docs as requested..."
- PYTHONPATH=. "$(PYTHON -f)" setup.py pudge || die "generating docs failed"
+ einfo "Generation of documentation"
+ PYTHONPATH="." "$(PYTHON -f)" setup.py build_sphinx || die "Generation of documentation failed"
fi
}
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests-${PYTHON_ABI}
- }
- python_execute_function testing
-}
-
src_install() {
distutils_src_install
- use doc && dohtml -r docs/html/*
+
+ if use doc; then
+ pushd build/sphinx/html > /dev/null
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html" || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
}