summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-09-22 21:25:31 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-09-22 21:25:31 +0000
commitbe01448d6a7da0cd5f3379ba5b9e960dc7b27c88 (patch)
tree6ddb5be4d9c722c0b7bcb52cc16bb7ee08d0b2ec /dev-python/oslotest
parentbup (diff)
downloadgentoo-2-be01448d6a7da0cd5f3379ba5b9e960dc7b27c88.tar.gz
gentoo-2-be01448d6a7da0cd5f3379ba5b9e960dc7b27c88.tar.bz2
gentoo-2-be01448d6a7da0cd5f3379ba5b9e960dc7b27c88.zip
bup
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/oslotest')
-rw-r--r--dev-python/oslotest/ChangeLog7
-rw-r--r--dev-python/oslotest/oslotest-1.1.0.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/oslotest/ChangeLog b/dev-python/oslotest/ChangeLog
index 5a47d5ac4a94..194b2f69aeb8 100644
--- a/dev-python/oslotest/ChangeLog
+++ b/dev-python/oslotest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/oslotest
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oslotest/ChangeLog,v 1.1 2014/08/01 05:21:50 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslotest/ChangeLog,v 1.2 2014/09/22 21:25:31 prometheanfire Exp $
+
+*oslotest-1.1.0 (22 Sep 2014)
+
+ 22 Sep 2014; Matthew Thode <prometheanfire@gentoo.org> +oslotest-1.1.0.ebuild:
+ bup
*oslotest-1.0.0 (01 Aug 2014)
diff --git a/dev-python/oslotest/oslotest-1.1.0.ebuild b/dev-python/oslotest/oslotest-1.1.0.ebuild
new file mode 100644
index 000000000000..f13cc4bdfdaf
--- /dev/null
+++ b/dev-python/oslotest/oslotest-1.1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslotest/oslotest-1.1.0.ebuild,v 1.1 2014/09/22 21:25:31 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack test framework and test fixtures"
+HOMEPAGE="https://pypi.python.org/pypi/oslotest"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hacking-0.9.2[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.10[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.2.0[${PYTHON_USEDEP}]
+ )"
+RDEPEND=">=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/six-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/mox3-0.7.0[${PYTHON_USEDEP}]"
+
+# This time half the doc files are missing; Do you want them?
+
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}