summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2014-09-26 19:42:48 +0000
committerAlex Brandt <alunduil@gentoo.org>2014-09-26 19:42:48 +0000
commit5cf8859c7f88337446449308276f3891487dfd4b (patch)
tree6d31808a82fe64a9f08b9802a8c1f44b10dc8a27 /dev-python/oslo-sphinx
parentfixed cvs sticky options on file(s) that should not have cvs keyword expansion (diff)
downloadgentoo-2-5cf8859c7f88337446449308276f3891487dfd4b.tar.gz
gentoo-2-5cf8859c7f88337446449308276f3891487dfd4b.tar.bz2
gentoo-2-5cf8859c7f88337446449308276f3891487dfd4b.zip
add python3_3 to oslo-sphinx-2.2.0
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 92FEA28B)
Diffstat (limited to 'dev-python/oslo-sphinx')
-rw-r--r--dev-python/oslo-sphinx/ChangeLog7
-rw-r--r--dev-python/oslo-sphinx/oslo-sphinx-2.2.0-r1.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-python/oslo-sphinx/ChangeLog b/dev-python/oslo-sphinx/ChangeLog
index ebe16106be95..07e987be6114 100644
--- a/dev-python/oslo-sphinx/ChangeLog
+++ b/dev-python/oslo-sphinx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/oslo-sphinx
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oslo-sphinx/ChangeLog,v 1.6 2014/09/22 21:24:06 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslo-sphinx/ChangeLog,v 1.7 2014/09/26 19:42:48 alunduil Exp $
+
+*oslo-sphinx-2.2.0-r1 (26 Sep 2014)
+
+ 26 Sep 2014; Alex Brandt <alunduil@gentoo.org> +oslo-sphinx-2.2.0-r1.ebuild:
+ add python3_3 target
*oslo-sphinx-2.2.0 (22 Sep 2014)
diff --git a/dev-python/oslo-sphinx/oslo-sphinx-2.2.0-r1.ebuild b/dev-python/oslo-sphinx/oslo-sphinx-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..992b572fa9a1
--- /dev/null
+++ b/dev-python/oslo-sphinx/oslo-sphinx-2.2.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslo-sphinx/oslo-sphinx-2.2.0-r1.ebuild,v 1.1 2014/09/26 19:42:48 alunduil Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 )
+
+inherit distutils-r1
+
+MY_PN="${PN//-/}"
+
+DESCRIPTION="OpenStack Sphinx Extensions"
+HOMEPAGE="http://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# NOTE: dev-python/hacking is unecessary as there are no tests
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+"
+RDEPEND=""