summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-09-22 21:26:28 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-09-22 21:26:28 +0000
commit7794e1bb9a5e12649d6c7748ca87dbe3d669d44a (patch)
tree097d3729189399372c59efd7610e4e0335d2b10e /dev-python/oslo-config
parentbup (diff)
downloadgentoo-2-7794e1bb9a5e12649d6c7748ca87dbe3d669d44a.tar.gz
gentoo-2-7794e1bb9a5e12649d6c7748ca87dbe3d669d44a.tar.bz2
gentoo-2-7794e1bb9a5e12649d6c7748ca87dbe3d669d44a.zip
bup
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/oslo-config')
-rw-r--r--dev-python/oslo-config/ChangeLog8
-rw-r--r--dev-python/oslo-config/oslo-config-1.4.0.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/oslo-config/ChangeLog b/dev-python/oslo-config/ChangeLog
index 2cd4ce6cf7a3..18d7b6dc3225 100644
--- a/dev-python/oslo-config/ChangeLog
+++ b/dev-python/oslo-config/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/oslo-config
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oslo-config/ChangeLog,v 1.8 2014/08/01 05:23:26 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslo-config/ChangeLog,v 1.9 2014/09/22 21:26:28 prometheanfire Exp $
+
+*oslo-config-1.4.0 (22 Sep 2014)
+
+ 22 Sep 2014; Matthew Thode <prometheanfire@gentoo.org>
+ +oslo-config-1.4.0.ebuild:
+ bup
*oslo-config-1.3.0 (01 Aug 2014)
diff --git a/dev-python/oslo-config/oslo-config-1.4.0.ebuild b/dev-python/oslo-config/oslo-config-1.4.0.ebuild
new file mode 100644
index 000000000000..9709ce7f5569
--- /dev/null
+++ b/dev-python/oslo-config/oslo-config-1.4.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslo-config/oslo-config-1.4.0.ebuild,v 1.1 2014/09/22 21:26:28 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="The Oslo configuration API supports parsing command line arguments
+and ini style configuration files"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.config"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.config/oslo.config-${PV}.tar.gz"
+S="${WORKDIR}/oslo.config-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hacking-0.9.2[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.10[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.1[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ )"
+RDEPEND=">=dev-python/netaddr-0.7.12[${PYTHON_USEDEP}]
+ >=dev-python/six-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-0.14[${PYTHON_USEDEP}]"
+
+# This time half the doc files are missing; Do you want them?
+
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}