summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-07-30 05:37:12 +0000
committerIan Delaney <idella4@gentoo.org>2014-07-30 05:37:12 +0000
commitf24f8327c138bf175873317dbcd47a258f213f60 (patch)
tree052d042920242c7aef65cb59b83dc97e5a8976b9 /dev-python/oct2py
parentfixing bug 517954 (diff)
downloadgentoo-2-f24f8327c138bf175873317dbcd47a258f213f60.tar.gz
gentoo-2-f24f8327c138bf175873317dbcd47a258f213f60.tar.bz2
gentoo-2-f24f8327c138bf175873317dbcd47a258f213f60.zip
drop py2.6 add py3.4 support
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/oct2py')
-rw-r--r--dev-python/oct2py/ChangeLog5
-rw-r--r--dev-python/oct2py/oct2py-1.3.0-r1.ebuild6
2 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/oct2py/ChangeLog b/dev-python/oct2py/ChangeLog
index 01ab263eefe1..966c6f025875 100644
--- a/dev-python/oct2py/ChangeLog
+++ b/dev-python/oct2py/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/oct2py
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/ChangeLog,v 1.16 2014/05/29 15:42:10 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/ChangeLog,v 1.17 2014/07/30 05:37:12 idella4 Exp $
+
+ 30 Jul 2014; Ian Delaney <idella4@gentoo.org> oct2py-1.3.0-r1.ebuild:
+ drop py2.6 add py3.4 support
*oct2py-1.3.0-r1 (29 May 2014)
diff --git a/dev-python/oct2py/oct2py-1.3.0-r1.ebuild b/dev-python/oct2py/oct2py-1.3.0-r1.ebuild
index 30da90cc21dd..de3348b0152b 100644
--- a/dev-python/oct2py/oct2py-1.3.0-r1.ebuild
+++ b/dev-python/oct2py/oct2py-1.3.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/oct2py-1.3.0-r1.ebuild,v 1.1 2014/05/29 15:42:10 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/oct2py-1.3.0-r1.ebuild,v 1.2 2014/07/30 05:37:12 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_3} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit distutils-r1
@@ -45,7 +45,7 @@ python_compile_all() {
python_test() {
unset DISPLAY
- if [[ ${EPYTHON} == python2* ]]; then
+ if [[ ${EPYTHON} == python2.7 ]]; then
local OPTIONS="--with-doctest"
fi
nosetests oct2py ${OPTIONS} || die "Tests fail with ${EPYTHON}"