summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-21 18:05:21 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-21 18:05:21 +0000
commitc9ae8fa9b5cafdfadebcb363fd5c9c2a5c716b4f (patch)
treefa11ca720e40269aa39b74216b5ed0226bdae928 /dev-python/numpy
parentRemove fortran from default USE, this is now handled by virtual/fortran and f... (diff)
downloadgentoo-2-c9ae8fa9b5cafdfadebcb363fd5c9c2a5c716b4f.tar.gz
gentoo-2-c9ae8fa9b5cafdfadebcb363fd5c9c2a5c716b4f.tar.bz2
gentoo-2-c9ae8fa9b5cafdfadebcb363fd5c9c2a5c716b4f.zip
Use USE=lapack to depend conditionally on fortran support
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/ChangeLog6
-rw-r--r--dev-python/numpy/numpy-1.5.1.ebuild14
-rw-r--r--dev-python/numpy/numpy-1.6.0.ebuild16
3 files changed, 18 insertions, 18 deletions
diff --git a/dev-python/numpy/ChangeLog b/dev-python/numpy/ChangeLog
index fa7d08b82a96..44c438fdc10f 100644
--- a/dev-python/numpy/ChangeLog
+++ b/dev-python/numpy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/numpy
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.146 2011/06/21 16:12:21 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.147 2011/06/21 18:05:21 jlec Exp $
+
+ 21 Jun 2011; Justin Lecher <jlec@gentoo.org> numpy-1.5.1.ebuild,
+ numpy-1.6.0.ebuild:
+ Use USE=lapack to depend conditionally on fortran support
21 Jun 2011; Justin Lecher <jlec@gentoo.org> numpy-1.5.1.ebuild,
numpy-1.6.0.ebuild:
diff --git a/dev-python/numpy/numpy-1.5.1.ebuild b/dev-python/numpy/numpy-1.5.1.ebuild
index a6346d6b5e7f..b891e950a808 100644
--- a/dev-python/numpy/numpy-1.5.1.ebuild
+++ b/dev-python/numpy/numpy-1.5.1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.5.1.ebuild,v 1.17 2011/06/21 16:12:21 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.5.1.ebuild,v 1.18 2011/06/21 18:05:21 jlec Exp $
+
+EAPI=3
-EAPI="3"
PYTHON_DEPEND="*"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="*-jython"
@@ -27,8 +28,7 @@ IUSE="doc lapack test"
RDEPEND="
dev-python/setuptools
- virtual/fortran
- lapack? ( virtual/cblas virtual/lapack )"
+ lapack? ( virtual/cblas virtual/lapack virtual/fortran )"
DEPEND="${RDEPEND}
doc? ( app-arch/unzip )
lapack? ( dev-util/pkgconfig )
@@ -39,7 +39,7 @@ PYTHON_CFLAGS=("* + -fno-strict-aliasing")
DOCS="COMPATIBILITY DEV_README.txt THANKS.txt"
pkg_setup() {
- fortran-2_pkg_setup
+ use lapack && fortran-2_pkg_setup
python_pkg_setup
# See progress in http://projects.scipy.org/scipy/numpy/ticket/573
@@ -53,9 +53,7 @@ pkg_setup() {
# linking with cblas and lapack library will force
# autodetecting and linking to all available fortran compilers
use lapack || return
- [[ -z ${FC} ]] && FC=$(tc-getFC)
- # when fortran flags are set, pic is removed.
- FFLAGS="${FFLAGS} -fPIC"
+ append-fflags -fPIC
NUMPY_FCONFIG="config_fc --noopt --noarch"
# workaround bug 335908
[[ ${FC} == *gfortran* ]] && NUMPY_FCONFIG="${NUMPY_FCONFIG} --fcompiler=gnu95"
diff --git a/dev-python/numpy/numpy-1.6.0.ebuild b/dev-python/numpy/numpy-1.6.0.ebuild
index 41cab9c2f73f..fe3e40e88e94 100644
--- a/dev-python/numpy/numpy-1.6.0.ebuild
+++ b/dev-python/numpy/numpy-1.6.0.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.6.0.ebuild,v 1.7 2011/06/21 16:12:21 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.6.0.ebuild,v 1.8 2011/06/21 18:05:21 jlec Exp $
+
+EAPI=3
-EAPI="3"
PYTHON_DEPEND="*"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="*-jython"
-inherit distutils flag-o-matic toolchain-funcs versionator
+inherit distutils flag-o-matic fortran-2 toolchain-funcs versionator
DOC_P="${PN}-1.5"
@@ -27,8 +28,7 @@ IUSE="doc lapack test"
RDEPEND="
dev-python/setuptools
- virtual/fortran
- lapack? ( virtual/cblas virtual/lapack )"
+ lapack? ( virtual/cblas virtual/lapack virtual/fortran )"
DEPEND="${RDEPEND}
doc? ( app-arch/unzip )
lapack? ( dev-util/pkgconfig )
@@ -42,7 +42,7 @@ PYTHON_NONVERSIONED_EXECUTABLES=("/usr/bin/f2py[[:digit:]]+\.[[:digit:]]+")
DOCS="COMPATIBILITY DEV_README.txt THANKS.txt"
pkg_setup() {
- fortran-2_pkg_setup
+ use lapack && fortran-2_pkg_setup
python_pkg_setup
# See progress in http://projects.scipy.org/scipy/numpy/ticket/573
@@ -56,9 +56,7 @@ pkg_setup() {
# linking with cblas and lapack library will force
# autodetecting and linking to all available fortran compilers
if use lapack; then
- [[ -z ${FC} ]] && FC=$(tc-getFC)
- # when fortran flags are set, pic is removed.
- FFLAGS="${FFLAGS} -fPIC"
+ append-fflags -fPIC
NUMPY_FCONFIG="config_fc --noopt --noarch"
# workaround bug 335908
[[ ${FC} == *gfortran* ]] && NUMPY_FCONFIG+=" --fcompiler=gnu95"