summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-02-19 20:17:29 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-02-19 20:17:29 +0000
commit9e97e9325f33556766ad034c280a9ac45cf4cd8f (patch)
tree9d69e2724ad11273ca35ecba70445112928900f8 /dev-python/numpy
parentkde support requires dbus. Bug #452778 (diff)
downloadgentoo-2-9e97e9325f33556766ad034c280a9ac45cf4cd8f.tar.gz
gentoo-2-9e97e9325f33556766ad034c280a9ac45cf4cd8f.tar.bz2
gentoo-2-9e97e9325f33556766ad034c280a9ac45cf4cd8f.zip
Version bump. Modified patch accordingly, and URL for docs.
(Portage version: 2.2.01.21688-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/ChangeLog8
-rw-r--r--dev-python/numpy/files/numpy-1.7.0-atlas.patch17
-rw-r--r--dev-python/numpy/metadata.xml9
-rw-r--r--dev-python/numpy/numpy-1.7.0.ebuild145
4 files changed, 175 insertions, 4 deletions
diff --git a/dev-python/numpy/ChangeLog b/dev-python/numpy/ChangeLog
index b49ad0d80fa5..4e17b8ecd9a6 100644
--- a/dev-python/numpy/ChangeLog
+++ b/dev-python/numpy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/numpy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.187 2013/02/19 15:34:06 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.188 2013/02/19 20:17:28 bicatali Exp $
+
+*numpy-1.7.0 (19 Feb 2013)
+
+ 19 Feb 2013; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/numpy-1.7.0-atlas.patch, +numpy-1.7.0.ebuild, metadata.xml:
+ Version bump. Modified patch accordingly, and URL for docs.
19 Feb 2013; Justin Lecher <jlec@gentoo.org> numpy-1.6.2.ebuild,
numpy-1.6.2-r2.ebuild:
diff --git a/dev-python/numpy/files/numpy-1.7.0-atlas.patch b/dev-python/numpy/files/numpy-1.7.0-atlas.patch
new file mode 100644
index 000000000000..b2936a9eb878
--- /dev/null
+++ b/dev-python/numpy/files/numpy-1.7.0-atlas.patch
@@ -0,0 +1,17 @@
+--- numpy/distutils/system_info.py.orig 2013-02-19 10:15:10.183780548 -0800
++++ numpy/distutils/system_info.py 2013-02-19 10:17:03.565350549 -0800
+@@ -282,13 +282,7 @@
+ 1 - display warning message
+ 2 - raise error
+ """
+- cl = {'atlas': atlas_info, # use lapack_opt or blas_opt instead
+- 'atlas_threads': atlas_threads_info, # ditto
+- 'atlas_blas': atlas_blas_info,
+- 'atlas_blas_threads': atlas_blas_threads_info,
+- 'lapack_atlas': lapack_atlas_info, # use lapack_opt instead
+- 'lapack_atlas_threads': lapack_atlas_threads_info, # ditto
+- 'mkl': mkl_info,
++ cl = {'mkl': mkl_info,
+ 'lapack_mkl': lapack_mkl_info, # use lapack_opt instead
+ 'blas_mkl': blas_mkl_info, # use blas_opt instead
+ 'x11': x11_info,
diff --git a/dev-python/numpy/metadata.xml b/dev-python/numpy/metadata.xml
index 3ee58f645122..bb330b7fd39b 100644
--- a/dev-python/numpy/metadata.xml
+++ b/dev-python/numpy/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <herd>python</herd>
- <longdescription lang="en">
+<herd>sci</herd>
+<herd>python</herd>
+<longdescription lang="en">
NumPy is a general-purpose array-processing Python package designed to
efficiently manipulate large multi-dimensional arrays of arbitrary
records without sacrificing too much speed for small multi-dimensional
@@ -11,4 +11,7 @@
basic linear algebra and random number generation.
It is the successor of Numeric and numarray.
</longdescription>
+<upstream>
+ <remote-id type="pypi">numpy</remote-id>
+</upstream>
</pkgmetadata>
diff --git a/dev-python/numpy/numpy-1.7.0.ebuild b/dev-python/numpy/numpy-1.7.0.ebuild
new file mode 100644
index 000000000000..9d504d68ecca
--- /dev/null
+++ b/dev-python/numpy/numpy-1.7.0.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.7.0.ebuild,v 1.1 2013/02/19 20:17:28 bicatali Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+
+FORTRAN_NEEDED=lapack
+
+inherit distutils-r1 eutils flag-o-matic fortran-2 multilib toolchain-funcs versionator
+
+DOC_PV="${PV}"
+
+DESCRIPTION="Fast array and numerical python library"
+HOMEPAGE="http://numpy.scipy.org/"
+SRC_URI="mirror://sourceforge/numpy/${P}.tar.gz
+ doc? (
+ http://docs.scipy.org/doc/${P}/${PN}-html-${DOC_PV}.zip
+ http://docs.scipy.org/doc/${P}/${PN}-ref-${DOC_PV}.pdf
+ http://docs.scipy.org/doc/${P}/${PN}-user-${DOC_PV}.pdf
+ )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc lapack test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ lapack? ( virtual/cblas virtual/lapack )"
+DEPEND="${RDEPEND}
+ doc? ( app-arch/unzip )
+ lapack? ( virtual/pkgconfig )
+ test? ( >=dev-python/nose-0.10[${PYTHON_USEDEP}] )"
+
+# Uses distutils.command.config.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ if use doc; then
+ unzip -qo "${DISTDIR}"/${PN}-html-${DOC_PV}.zip -d html || die
+ fi
+}
+
+pc_incdir() {
+ $(tc-getPKG_CONFIG) --cflags-only-I $@ | \
+ sed -e 's/^-I//' -e 's/[ ]*-I/:/g'
+}
+
+pc_libdir() {
+ $(tc-getPKG_CONFIG) --libs-only-L $@ | \
+ sed -e 's/^-L//' -e 's/[ ]*-L/:/g'
+}
+
+pc_libs() {
+ $(tc-getPKG_CONFIG) --libs-only-l $@ | \
+ sed -e 's/[ ]-l*\(pthread\|m\)[ ]*//g' \
+ -e 's/^-l//' -e 's/[ ]*-l/,/g'
+}
+
+python_prepare_all() {
+ epatch "${FILESDIR}"/${PN}-1.7.0-atlas.patch
+
+ if use lapack; then
+ append-ldflags "$($(tc-getPKG_CONFIG) --libs-only-other cblas lapack)"
+ local libdir="${EPREFIX}"/usr/$(get_libdir)
+ # make sure _dotblas.so gets built
+ sed -i -e '/NO_ATLAS_INFO/,+1d' numpy/core/setup.py || die
+ cat >> site.cfg <<-EOF
+ [blas]
+ include_dirs = $(pc_incdir cblas)
+ library_dirs = $(pc_libdir cblas blas):${libdir}
+ blas_libs = $(pc_libs cblas blas)
+ [lapack]
+ library_dirs = $(pc_libdir lapack):${libdir}
+ lapack_libs = $(pc_libs lapack)
+ EOF
+ else
+ export {ATLAS,PTATLAS,BLAS,LAPACK,MKL}=None
+ fi
+
+ export CC="$(tc-getCC) ${CFLAGS}"
+
+ append-flags -fno-strict-aliasing
+
+ # See progress in http://projects.scipy.org/scipy/numpy/ticket/573
+ # with the subtle difference that we don't want to break Darwin where
+ # -shared is not a valid linker argument
+ if [[ ${CHOST} != *-darwin* ]]; then
+ append-ldflags -shared
+ fi
+
+ # only one fortran to link with:
+ # linking with cblas and lapack library will force
+ # autodetecting and linking to all available fortran compilers
+ if use lapack; then
+ append-fflags -fPIC
+ NUMPY_FCONFIG="config_fc --noopt --noarch"
+ # workaround bug 335908
+ [[ $(tc-getFC) == *gfortran* ]] && NUMPY_FCONFIG+=" --fcompiler=gnu95"
+ fi
+
+ # don't version f2py, we will handle it.
+ sed -i -e '/f2py_exe/s:+os\.path.*$::' numpy/f2py/setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile ${NUMPY_FCONFIG}
+}
+
+python_test() {
+ distutils_install_for_testing ${NUMPY_FCONFIG}
+
+ cd "${TMPDIR}" || die
+ "${PYTHON}" -c "
+import numpy, sys
+r = numpy.test()
+sys.exit(0 if r.wasSuccessful() else 1)" || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install ${NUMPY_FCONFIG}
+
+ rm -f "${D}"$(python_get_sitedir)/numpy/*.txt
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ dodoc COMPATIBILITY DEV_README.txt THANKS.txt
+
+ docinto f2py
+ dodoc numpy/f2py/docs/*.txt
+ doman numpy/f2py/f2py.1
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r "${WORKDIR}"/html
+ doins "${DISTDIR}"/${PN}-{user,ref}-${DOC_PV}.pdf
+ fi
+}