summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-30 01:59:25 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-30 01:59:25 +0000
commit3551d44c80bcf1db801b9202c296fd4ccbd7768f (patch)
treeab37ce1a62141e6ab78557bdeba6bd9148c9aa0c /dev-python/numpy
parentBlock eject as the two collides. (diff)
downloadgentoo-2-3551d44c80bcf1db801b9202c296fd4ccbd7768f.tar.gz
gentoo-2-3551d44c80bcf1db801b9202c296fd4ccbd7768f.tar.bz2
gentoo-2-3551d44c80bcf1db801b9202c296fd4ccbd7768f.zip
Set PYTHON_DEPEND.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/ChangeLog7
-rw-r--r--dev-python/numpy/numpy-1.2.1.ebuild6
-rw-r--r--dev-python/numpy/numpy-1.3.0-r1.ebuild8
-rw-r--r--dev-python/numpy/numpy-1.3.0-r2.ebuild7
-rw-r--r--dev-python/numpy/numpy-1.4.1.ebuild7
5 files changed, 20 insertions, 15 deletions
diff --git a/dev-python/numpy/ChangeLog b/dev-python/numpy/ChangeLog
index 57283d14e2b3..020b7845157d 100644
--- a/dev-python/numpy/ChangeLog
+++ b/dev-python/numpy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/numpy
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.109 2010/04/22 19:26:48 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.110 2010/06/30 01:59:25 arfrever Exp $
+
+ 30 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ numpy-1.2.1.ebuild, numpy-1.3.0-r1.ebuild, numpy-1.3.0-r2.ebuild,
+ numpy-1.4.1.ebuild:
+ Set PYTHON_DEPEND.
*numpy-1.4.1 (22 Apr 2010)
diff --git a/dev-python/numpy/numpy-1.2.1.ebuild b/dev-python/numpy/numpy-1.2.1.ebuild
index 515f7952c480..9af236bd6105 100644
--- a/dev-python/numpy/numpy-1.2.1.ebuild
+++ b/dev-python/numpy/numpy-1.2.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.2.1.ebuild,v 1.15 2009/08/09 16:45:48 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.2.1.ebuild,v 1.16 2010/06/30 01:59:25 arfrever Exp $
-NEED_PYTHON=2.4
+PYTHON_DEPEND="2"
inherit distutils eutils flag-o-matic fortran
diff --git a/dev-python/numpy/numpy-1.3.0-r1.ebuild b/dev-python/numpy/numpy-1.3.0-r1.ebuild
index f6a7e6f4f2c6..0c524794e657 100644
--- a/dev-python/numpy/numpy-1.3.0-r1.ebuild
+++ b/dev-python/numpy/numpy-1.3.0-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.3.0-r1.ebuild,v 1.10 2010/01/06 21:11:02 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.3.0-r1.ebuild,v 1.11 2010/06/30 01:59:25 arfrever Exp $
EAPI="2"
-
-NEED_PYTHON="2.4"
+PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils eutils flag-o-matic toolchain-funcs
@@ -24,8 +24,6 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
LICENSE="BSD"
-RESTRICT_PYTHON_ABIS="3*"
-
pkg_setup() {
# whatever LDFLAGS set will break linking
# see progress in http://projects.scipy.org/scipy/numpy/ticket/573
diff --git a/dev-python/numpy/numpy-1.3.0-r2.ebuild b/dev-python/numpy/numpy-1.3.0-r2.ebuild
index ba3c90944c26..ec8fb62a8321 100644
--- a/dev-python/numpy/numpy-1.3.0-r2.ebuild
+++ b/dev-python/numpy/numpy-1.3.0-r2.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.3.0-r2.ebuild,v 1.3 2009/12/28 02:34:00 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.3.0-r2.ebuild,v 1.4 2010/06/30 01:59:25 arfrever Exp $
EAPI="2"
+PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils eutils flag-o-matic toolchain-funcs versionator
@@ -29,7 +31,6 @@ DEPEND="${RDEPEND}
lapack? ( dev-util/pkgconfig )
test? ( >=dev-python/nose-0.10 )
doc? ( app-arch/unzip )"
-RESTRICT_PYTHON_ABIS="3.*"
pkg_setup() {
# See progress in http://projects.scipy.org/scipy/numpy/ticket/573
diff --git a/dev-python/numpy/numpy-1.4.1.ebuild b/dev-python/numpy/numpy-1.4.1.ebuild
index 4d53dfa566f0..32a0bdd3899a 100644
--- a/dev-python/numpy/numpy-1.4.1.ebuild
+++ b/dev-python/numpy/numpy-1.4.1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.4.1.ebuild,v 1.1 2010/04/22 19:26:48 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.4.1.ebuild,v 1.2 2010/06/30 01:59:25 arfrever Exp $
-EAPI="2"
+EAPI="3"
+PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils eutils flag-o-matic toolchain-funcs versionator
@@ -29,7 +31,6 @@ DEPEND="${RDEPEND}
lapack? ( dev-util/pkgconfig )
test? ( >=dev-python/nose-0.10 )
doc? ( app-arch/unzip )"
-RESTRICT_PYTHON_ABIS="3.*"
pkg_setup() {
# See progress in http://projects.scipy.org/scipy/numpy/ticket/573