summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-21 09:40:15 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-21 09:40:15 +0000
commitbfff3be3413a1e420d05201f38c120c7016a3e8c (patch)
treed78a34f2aa961f2da5bcebfdb91b51bcfeda7747 /dev-python/numpy/numpy-1.5.1.ebuild
parentAdded fortran-2.eclass support (diff)
downloadgentoo-2-bfff3be3413a1e420d05201f38c120c7016a3e8c.tar.gz
gentoo-2-bfff3be3413a1e420d05201f38c120c7016a3e8c.tar.bz2
gentoo-2-bfff3be3413a1e420d05201f38c120c7016a3e8c.zip
Added fortran-2.eclass support
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/numpy/numpy-1.5.1.ebuild')
-rw-r--r--dev-python/numpy/numpy-1.5.1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/numpy/numpy-1.5.1.ebuild b/dev-python/numpy/numpy-1.5.1.ebuild
index e71ecd37933c..e86b4e1b7e6a 100644
--- a/dev-python/numpy/numpy-1.5.1.ebuild
+++ b/dev-python/numpy/numpy-1.5.1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.5.1.ebuild,v 1.15 2011/04/03 11:46:01 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.5.1.ebuild,v 1.16 2011/06/21 09:40:15 jlec Exp $
EAPI="3"
PYTHON_DEPEND="*"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="*-jython"
-inherit distutils eutils flag-o-matic toolchain-funcs versionator
+inherit distutils eutils fortran-2 flag-o-matic toolchain-funcs versionator
NP="${PN}-1.5"
@@ -37,6 +37,7 @@ PYTHON_CFLAGS=("* + -fno-strict-aliasing")
DOCS="COMPATIBILITY DEV_README.txt THANKS.txt"
pkg_setup() {
+ fortran-2_pkg_setup
python_pkg_setup
# See progress in http://projects.scipy.org/scipy/numpy/ticket/573