summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-02-07 17:14:57 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-02-07 17:14:57 +0000
commit11c7d44960a3294e06bd659ccbcbb93b5e8bbf25 (patch)
treeda070a8922a62553b745cb200cbd98392cc357cb /dev-python/numeric
parentversion bump (diff)
downloadgentoo-2-11c7d44960a3294e06bd659ccbcbb93b5e8bbf25.tar.gz
gentoo-2-11c7d44960a3294e06bd659ccbcbb93b5e8bbf25.tar.bz2
gentoo-2-11c7d44960a3294e06bd659ccbcbb93b5e8bbf25.zip
fixing bug #114885 and others for numeric-24.2
(Portage version: 2.1.1-r2)
Diffstat (limited to 'dev-python/numeric')
-rw-r--r--dev-python/numeric/ChangeLog14
-rw-r--r--dev-python/numeric/files/digest-numeric-24.2-r13
-rw-r--r--dev-python/numeric/files/numeric-24.2-arrayobject.patch11
-rw-r--r--dev-python/numeric/files/numeric-24.2-eigen.patch11
-rw-r--r--dev-python/numeric/files/numeric-24.2-lapack.patch34
-rw-r--r--dev-python/numeric/files/numeric-24.2-umath.patch14
-rw-r--r--dev-python/numeric/metadata.xml7
-rw-r--r--dev-python/numeric/numeric-24.2-r1.ebuild49
8 files changed, 141 insertions, 2 deletions
diff --git a/dev-python/numeric/ChangeLog b/dev-python/numeric/ChangeLog
index e928cc831f5e..72c3c91070b8 100644
--- a/dev-python/numeric/ChangeLog
+++ b/dev-python/numeric/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-python/numeric
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numeric/ChangeLog,v 1.26 2006/07/28 20:05:01 the_paya Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numeric/ChangeLog,v 1.27 2007/02/07 17:14:57 bicatali Exp $
+
+*numeric-24.2-r1 (07 Feb 2007)
+
+ 07 Feb 2007; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/numeric-24.2-arrayobject.patch, +files/numeric-24.2-eigen.patch,
+ +files/numeric-24.2-lapack.patch, +files/numeric-24.2-umath.patch,
+ metadata.xml, +numeric-24.2-r1.ebuild:
+ Fixed an include placement for math.h, allowing acosh and asinh, an
+ eigenvalue solver hang and a memory leak. Closing bug #114885. Added
+ longdescription in metadata.xml.
28 Jul 2006; Javier Villavicencio <the_paya@gentoo.org>
numeric-24.2.ebuild:
diff --git a/dev-python/numeric/files/digest-numeric-24.2-r1 b/dev-python/numeric/files/digest-numeric-24.2-r1
new file mode 100644
index 000000000000..b891af10ea95
--- /dev/null
+++ b/dev-python/numeric/files/digest-numeric-24.2-r1
@@ -0,0 +1,3 @@
+MD5 2ae672656e06716a149acb048cca3093 Numeric-24.2.tar.gz 743800
+RMD160 c9502db28663558c535e236392c9beddec9743bb Numeric-24.2.tar.gz 743800
+SHA256 5f72e729eb6ff57442f2a38bfc9931738b59e5077928e2e70d22b4610ff15258 Numeric-24.2.tar.gz 743800
diff --git a/dev-python/numeric/files/numeric-24.2-arrayobject.patch b/dev-python/numeric/files/numeric-24.2-arrayobject.patch
new file mode 100644
index 000000000000..a67d5b4f501e
--- /dev/null
+++ b/dev-python/numeric/files/numeric-24.2-arrayobject.patch
@@ -0,0 +1,11 @@
+--- Numeric-24.2/Src/arrayobject.c 2005-11-11 07:30:18.000000000 +0000
++++ Numeric-24.2.new/Src/arrayobject.c 2006-06-06 19:13:58.000000000 +0100
+@@ -1866,7 +1866,7 @@
+ for (i=0; i<sz; i++) {
+ v=array_item((PyArrayObject *)self, i);
+ PyList_SetItem(lp, i, PyArray_ToList(v));
+- if (((PyArrayObject *)self)->nd>1){
++ if (((PyArrayObject *)self)->nd>0){
+ Py_DECREF(v);
+ }
+ }
diff --git a/dev-python/numeric/files/numeric-24.2-eigen.patch b/dev-python/numeric/files/numeric-24.2-eigen.patch
new file mode 100644
index 000000000000..331d0f11a62e
--- /dev/null
+++ b/dev-python/numeric/files/numeric-24.2-eigen.patch
@@ -0,0 +1,11 @@
+--- Numeric-24.2/Src/dlamch.c.fix-dlamc3 2006-10-29 22:30:52.000000000 -0500
++++ Numeric-24.2/Src/dlamch.c 2006-10-29 22:31:00.000000000 -0500
+@@ -672,7 +672,7 @@
+ */
+ /* >>Start of File<<
+ System generated locals */
+- doublereal ret_val;
++ volatile doublereal ret_val;
+
+
+
diff --git a/dev-python/numeric/files/numeric-24.2-lapack.patch b/dev-python/numeric/files/numeric-24.2-lapack.patch
new file mode 100644
index 000000000000..bb77b77c8a77
--- /dev/null
+++ b/dev-python/numeric/files/numeric-24.2-lapack.patch
@@ -0,0 +1,34 @@
+--- Numeric-24.2.orig/customize.py 2005-11-13 02:40:14.000000000 +0000
++++ Numeric-24.2/customize.py 2006-10-10 17:58:33.000000000 +0100
+@@ -13,9 +13,9 @@
+ # will be used, except on Mac OS X, where the vecLib framework will be used
+ # if found.
+
+-use_system_lapack = 0
++use_system_lapack = 1
+ lapack_library_dirs = []
+-lapack_libraries = []
++lapack_libraries = ['lapack', 'cblas', 'blas', 'atlas', 'g2c']
+ lapack_extra_link_args = []
+
+ # Example: using ATLAS
+@@ -35,8 +35,8 @@
+
+ # Set use_dotblas to 1 to use BLAS for the matrix multiplication routines.
+ # Put the directory that 'cblas.h' is in into dotblas_include_dirs
+-use_dotblas = 0
+-dotblas_include_dirs = []
++use_dotblas = 1
++dotblas_include_dirs = ['/usr/include/atlas']
+ dotblas_cblas_header = '<cblas.h>'
+ dotblas_library_dirs = lapack_library_dirs
+ dotblas_libraries = lapack_libraries
+@@ -45,7 +45,7 @@
+ # Example: using ATLAS
+ if 0:
+ use_dotblas = 1
+- dotblas_include_dirs = ['/usr/include/atlas']
++ dotblas_include_dirs = ['/usr/include/atlas','/usr/include/cblas']
+ dotblas_library_dirs = lapack_library_dirs
+ dotblas_libraries = ['cblas', 'atlas', 'g2c']
+
diff --git a/dev-python/numeric/files/numeric-24.2-umath.patch b/dev-python/numeric/files/numeric-24.2-umath.patch
new file mode 100644
index 000000000000..eb3d8b010885
--- /dev/null
+++ b/dev-python/numeric/files/numeric-24.2-umath.patch
@@ -0,0 +1,14 @@
+--- Numeric-24.2.orig/Src/umathmodule.c 2005-04-20 19:48:47.000000000 +0100
++++ Numeric-24.2/Src/umathmodule.c 2006-10-10 16:16:40.000000000 +0100
+@@ -1,9 +1,9 @@
+-
++#include <math.h>
+ #include "Python.h"
+ #include "Numeric/arrayobject.h"
+ #include "Numeric/ufuncobject.h"
+ #include "abstract.h"
+-#include <math.h>
++
+
+ #ifndef CHAR_BIT
+ #define CHAR_BIT 8
diff --git a/dev-python/numeric/metadata.xml b/dev-python/numeric/metadata.xml
index de483c53568f..bfa28bb2c37c 100644
--- a/dev-python/numeric/metadata.xml
+++ b/dev-python/numeric/metadata.xml
@@ -2,4 +2,11 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>python</herd>
+<longdescription lang="en">
+The Numeric Extensions to Python (NumPy) adds multi-dimensional array
+processing. These objects facilitates processing for manny numerical
+applications such as universal functions on arrays, FFTs and linear
+algebra. This package is being superseeded by numpy, and now inactive,
+but still used in various applications.
+</longdescription>
</pkgmetadata>
diff --git a/dev-python/numeric/numeric-24.2-r1.ebuild b/dev-python/numeric/numeric-24.2-r1.ebuild
new file mode 100644
index 000000000000..79aff0bd53fa
--- /dev/null
+++ b/dev-python/numeric/numeric-24.2-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numeric/numeric-24.2-r1.ebuild,v 1.1 2007/02/07 17:14:57 bicatali Exp $
+
+inherit distutils eutils
+
+MY_P=Numeric-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Numerical multidimensional array language facility for Python."
+HOMEPAGE="http://numeric.scipy.org/"
+SRC_URI="mirror://sourceforge/numpy/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3"
+
+
+src_unpack() {
+ unpack ${A}
+ # fix list problem
+ epatch "${FILESDIR}"/${P}-arrayobject.patch
+ # fix skips of acosh, asinh
+ epatch "${FILESDIR}"/${P}-umath.patch
+ # fix eigenvalue hang
+ epatch "${FILESDIR}"/${P}-eigen.patch
+}
+
+src_install() {
+ distutils_src_install
+ distutils_python_version
+
+ # Numerical Tutorial is nice for testing and learning
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages/NumTut
+ doins Demo/NumTut/*
+
+ # install various doc from packages
+ docinto FFT
+ dodoc Packages/FFT/MANIFEST
+ docinto MA
+ dodoc Packages/MA/{MANIFEST,README}
+ docinto RNG
+ dodoc Packages/RNG/{MANIFEST,README}
+ docinto lapack_lite
+ dodoc Misc/lapack_lite/README
+}