summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-11 22:58:00 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-11 22:58:00 +0000
commitb57fc899cbdc5491c5e96fbce29bbaa00cf34a64 (patch)
treedf8116ae15e27f0760933ac383036655a8d0dead /dev-python/numarray
parentDelete call to deprecated python_version(). (diff)
downloadgentoo-2-b57fc899cbdc5491c5e96fbce29bbaa00cf34a64.tar.gz
gentoo-2-b57fc899cbdc5491c5e96fbce29bbaa00cf34a64.tar.bz2
gentoo-2-b57fc899cbdc5491c5e96fbce29bbaa00cf34a64.zip
Delete call to deprecated distutils_python_version().
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/numarray')
-rw-r--r--dev-python/numarray/ChangeLog6
-rw-r--r--dev-python/numarray/numarray-1.5.2-r1.ebuild9
2 files changed, 9 insertions, 6 deletions
diff --git a/dev-python/numarray/ChangeLog b/dev-python/numarray/ChangeLog
index 64c034936fae..935b08bfeaad 100644
--- a/dev-python/numarray/ChangeLog
+++ b/dev-python/numarray/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/numarray
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numarray/ChangeLog,v 1.34 2010/02/07 20:43:52 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numarray/ChangeLog,v 1.35 2010/06/11 22:58:00 arfrever Exp $
+
+ 11 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ numarray-1.5.2-r1.ebuild:
+ Delete call to deprecated distutils_python_version().
07 Feb 2010; Peter Volkov <pva@gentoo.org> numarray-1.5.2-r1.ebuild:
Add inherit eutils: epatch is defined there.
diff --git a/dev-python/numarray/numarray-1.5.2-r1.ebuild b/dev-python/numarray/numarray-1.5.2-r1.ebuild
index 53038b53f37e..7c15c9be1cfe 100644
--- a/dev-python/numarray/numarray-1.5.2-r1.ebuild
+++ b/dev-python/numarray/numarray-1.5.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numarray/numarray-1.5.2-r1.ebuild,v 1.13 2010/02/07 20:43:52 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numarray/numarray-1.5.2-r1.ebuild,v 1.14 2010/06/11 22:58:00 arfrever Exp $
NEED_PYTHON=2.3
@@ -53,8 +53,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-freebsd.patch
# fix only for python-2.5 (fix still uncomplete, see bug #191240)
- distutils_python_version
- [[ "${PYVER}" == 2.5 ]] && epatch "${FILESDIR}"/${P}-python25.patch
+ [[ "$(python_get_version)" == 2.5 ]] && epatch "${FILESDIR}"/${P}-python25.patch
# array_protocol tests are buggy with various numeric/numpy versions
sed -i \
@@ -71,13 +70,13 @@ src_unpack() {
cfg_packages.py || die "sed for lapack failed"
fi
- "${python}" setup.py config --gencode || die "API code generation failed"
+ "$(PYTHON)" setup.py config --gencode || die "API code generation failed"
}
src_test() {
cd build/lib*
cp "${S}"/Lib/testdata.fits numarray
- PYTHONPATH=. "${python}" -c \
+ PYTHONPATH=. "$(PYTHON)" -c \
"from numarray.testall import test;import sys;sys.exit(test())" 2>&1 \
| tee test.log
grep -q -i failed test.log && die "failed tests in ${PWD}/test.log"