summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-02-07 11:10:13 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-02-07 11:10:13 +0000
commit9df78af99a17e94ca05a9ed9eeb171323c1303d3 (patch)
tree0b8521c0d2939e1c83c478133864299a19a99568 /dev-python/numarray/files
parentMarked stable on x86. (diff)
downloadgentoo-2-9df78af99a17e94ca05a9ed9eeb171323c1303d3.tar.gz
gentoo-2-9df78af99a17e94ca05a9ed9eeb171323c1303d3.tar.bz2
gentoo-2-9df78af99a17e94ca05a9ed9eeb171323c1303d3.zip
numarray-1.5.2 version bump
(Portage version: 2.1.1-r2)
Diffstat (limited to 'dev-python/numarray/files')
-rw-r--r--dev-python/numarray/files/digest-numarray-1.5.26
-rw-r--r--dev-python/numarray/files/numarray-1.5.2-html.patch20
-rw-r--r--dev-python/numarray/files/numarray-1.5.2-includes.patch56
-rw-r--r--dev-python/numarray/files/numarray-1.5.2-numinclude.patch11
4 files changed, 93 insertions, 0 deletions
diff --git a/dev-python/numarray/files/digest-numarray-1.5.2 b/dev-python/numarray/files/digest-numarray-1.5.2
new file mode 100644
index 000000000000..882e2bded563
--- /dev/null
+++ b/dev-python/numarray/files/digest-numarray-1.5.2
@@ -0,0 +1,6 @@
+MD5 d2ecfc60fe4869c328b872540d04e0f7 numarray-1.5.2.tar.gz 1196014
+RMD160 51cc7681958cada32c515872e8def6fc0ff296ca numarray-1.5.2.tar.gz 1196014
+SHA256 6f6dc1a348c2fa32b2179717f3b3af4ddf60e9a3417739d325f344eb8f243174 numarray-1.5.2.tar.gz 1196014
+MD5 c7b23442b8ead6aa7521f27049c41deb numarray-1.5.html.tar.gz 203409
+RMD160 361850242a04efea59befe7e05dd9cb6fa1cb457 numarray-1.5.html.tar.gz 203409
+SHA256 55d6322e83d78d6f0961ae563bf81602214fb44d47929a212f0342fb579346a6 numarray-1.5.html.tar.gz 203409
diff --git a/dev-python/numarray/files/numarray-1.5.2-html.patch b/dev-python/numarray/files/numarray-1.5.2-html.patch
new file mode 100644
index 000000000000..b2e4896d7bf4
--- /dev/null
+++ b/dev-python/numarray/files/numarray-1.5.2-html.patch
@@ -0,0 +1,20 @@
+--- numarray-1.5.2/Doc/manual/Makefile 2005-04-28 16:58:23.000000000 +0100
++++ numarray-1.5.2.new/Doc/manual/Makefile 2006-08-30 19:54:21.000000000 +0100
+@@ -52,7 +52,7 @@
+
+ dvi: numarray.dvi
+
+-html: numarray
++html: numarray.html
+
+ pdf: numarray.pdf
+
+@@ -71,7 +71,7 @@
+ echo "You need to create a link to mkhowto,"
+ echo "see the README for details."
+
+-numarray: Makefile mkhowto $(SOURCES)
++numarray.html: Makefile mkhowto $(SOURCES)
+ $(MKHOWTO) --html $(OPTIONS) numarray.tex
+
+ numarray.dvi: Makefile mkhowto $(SOURCES)
diff --git a/dev-python/numarray/files/numarray-1.5.2-includes.patch b/dev-python/numarray/files/numarray-1.5.2-includes.patch
new file mode 100644
index 000000000000..43536999bf3d
--- /dev/null
+++ b/dev-python/numarray/files/numarray-1.5.2-includes.patch
@@ -0,0 +1,56 @@
+diff -Nur numarray-1.5.2/Include/numarray/arraybase.h numarray-1.5.2.new/Include/numarray/arraybase.h
+--- numarray-1.5.2/Include/numarray/arraybase.h 2006-01-23 11:45:03.000000000 +0000
++++ numarray-1.5.2.new/Include/numarray/arraybase.h 2006-08-30 19:54:21.000000000 +0100
+@@ -1,6 +1,8 @@
+ #if !defined(_arraybase_h)
+ #define _arraybase_h 1
+
++#include <Python.h>
++
+ #if defined(SIZEOF_VOID_P)
+ #if SIZEOF_VOID_P == 8
+ #define LP64 1
+@@ -17,6 +19,8 @@
+ #define HAS_UINT64 1
+ #endif
+
++#include "numconfig.h"
++
+ #define REFCOUNT(obj) (((PyObject *)(obj))->ob_refcnt)
+ #define MAX_ELSIZE 16
+
+diff -Nur numarray-1.5.2/Include/numarray/cfunc.h numarray-1.5.2.new/Include/numarray/cfunc.h
+--- numarray-1.5.2/Include/numarray/cfunc.h 2005-10-27 22:06:35.000000000 +0100
++++ numarray-1.5.2.new/Include/numarray/cfunc.h 2006-08-30 19:54:21.000000000 +0100
+@@ -1,6 +1,8 @@
+ #if !defined(__cfunc__)
+ #define __cfunc__ 1
+
++#include <Python.h>
++
+ typedef PyObject *(*CFUNCasPyValue)(void *);
+ typedef int (*UFUNC)(long, long, long, void **, long*);
+ /* typedef void (*CFUNC_2ARG)(long, void *, void *); */
+diff -Nur numarray-1.5.2/Include/numarray/nummacro.h numarray-1.5.2.new/Include/numarray/nummacro.h
+--- numarray-1.5.2/Include/numarray/nummacro.h 2005-11-28 01:07:02.000000000 +0000
++++ numarray-1.5.2.new/Include/numarray/nummacro.h 2006-08-30 19:54:21.000000000 +0100
+@@ -1,6 +1,8 @@
+ #if !defined(_ndarraymacro)
+ #define _ndarraymacro
+
++#include <Python.h>
++
+ /* The structs defined here are private implementation details of numarray
+ which are subject to change w/o notice.
+ */
+diff -Nur numarray-1.5.2/Include/numarray/tc.h numarray-1.5.2.new/Include/numarray/tc.h
+--- numarray-1.5.2/Include/numarray/tc.h 2003-05-09 18:11:56.000000000 +0100
++++ numarray-1.5.2.new/Include/numarray/tc.h 2006-08-30 19:54:21.000000000 +0100
+@@ -1,5 +1,7 @@
+ #if defined(MEASURE_TIMING)
+
++#include <Python.h>
++
+ /* ----------------------------------------------------------------------- */
+
+ typedef struct
diff --git a/dev-python/numarray/files/numarray-1.5.2-numinclude.patch b/dev-python/numarray/files/numarray-1.5.2-numinclude.patch
new file mode 100644
index 000000000000..3da32fc56847
--- /dev/null
+++ b/dev-python/numarray/files/numarray-1.5.2-numinclude.patch
@@ -0,0 +1,11 @@
+--- numarray-1.5.2/Lib/numinclude.py 2006-08-24 19:40:48.000000000 +0100
++++ numarray-1.5.2.new/Lib/numinclude.py 2006-08-30 19:54:21.000000000 +0100
+@@ -4,7 +4,7 @@
+ import _ndarray
+ import os
+
+-include_dir = '/home/jmiller/work/debug/include/python2.5/numarray'
++include_dir = '/usr/include/python2.4/numarray'
+ version = '1.5.2'
+ hasUInt64 = _ndarray.hasUInt64()
+ LP64 = _ndarray.lp64()