summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-13 08:08:47 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-13 08:08:47 +0000
commitd35660c7fad83f67eeb975c286c18cd75ac25440 (patch)
tree84f450940c3b42d91520ce5839bb316c2b504808 /dev-python/notify-python
parentPkgmove eaccelerator (diff)
downloadgentoo-2-d35660c7fad83f67eeb975c286c18cd75ac25440.tar.gz
gentoo-2-d35660c7fad83f67eeb975c286c18cd75ac25440.tar.bz2
gentoo-2-d35660c7fad83f67eeb975c286c18cd75ac25440.zip
Revision bump to make sure people use the correct version of notify-python.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/notify-python')
-rw-r--r--dev-python/notify-python/ChangeLog8
-rw-r--r--dev-python/notify-python/notify-python-0.1.1-r2.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-python/notify-python/ChangeLog b/dev-python/notify-python/ChangeLog
index f0b34eb3a4dd..de42ab54e4d1 100644
--- a/dev-python/notify-python/ChangeLog
+++ b/dev-python/notify-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/notify-python
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/notify-python/ChangeLog,v 1.27 2011/01/29 16:20:21 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/notify-python/ChangeLog,v 1.28 2011/03/13 08:08:47 ssuominen Exp $
+
+*notify-python-0.1.1-r2 (13 Mar 2011)
+
+ 13 Mar 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +notify-python-0.1.1-r2.ebuild:
+ Revision bump to make sure people use the correct version of notify-python.
29 Jan 2011; Samuli Suominen <ssuominen@gentoo.org>
notify-python-0.1.1-r1.ebuild,
diff --git a/dev-python/notify-python/notify-python-0.1.1-r2.ebuild b/dev-python/notify-python/notify-python-0.1.1-r2.ebuild
new file mode 100644
index 000000000000..cd4694adc8b4
--- /dev/null
+++ b/dev-python/notify-python/notify-python-0.1.1-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/notify-python/notify-python-0.1.1-r2.ebuild,v 1.1 2011/03/13 08:08:47 ssuominen Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+
+inherit eutils python
+
+DESCRIPTION="Python bindings for libnotify"
+HOMEPAGE="http://www.galago-project.org/"
+SRC_URI="http://www.galago-project.org/files/releases/source/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-python/pygtk-2.4.0
+ >=x11-libs/libnotify-0.7"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+
+ # Disable byte-compilation.
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+
+ # Remove the old pynotify.c to ensure it's properly regenerated #212128.
+ rm -f src/pynotify.c
+
+ python_src_prepare
+}
+
+src_install() {
+ python_src_install
+ python_clean_installation_image
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ python_mod_optimize gtk-2.0/pynotify
+}
+
+pkg_postrm() {
+ python_mod_cleanup gtk-2.0/pynotify
+}