summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-03-02 12:40:32 +0000
committerIan Delaney <idella4@gentoo.org>2013-03-02 12:40:32 +0000
commite40eb392e8445546346d60a259749b9d55594044 (patch)
treed26abf5364c76ca1a7887febc3458c57ed21c2d3 /dev-python/nose
parentVersion bump. (diff)
downloadgentoo-2-e40eb392e8445546346d60a259749b9d55594044.tar.gz
gentoo-2-e40eb392e8445546346d60a259749b9d55594044.tar.bz2
gentoo-2-e40eb392e8445546346d60a259749b9d55594044.zip
Added skiptest.patch for 1.2.1 versions skipping tests set to fail, wrt Bug #455104
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/nose')
-rw-r--r--dev-python/nose/ChangeLog8
-rw-r--r--dev-python/nose/files/nose-1.2.1-skiptest.patch23
-rw-r--r--dev-python/nose/nose-1.2.1.ebuild8
-rw-r--r--dev-python/nose/nose-1.2.1_p2012.ebuild8
4 files changed, 40 insertions, 7 deletions
diff --git a/dev-python/nose/ChangeLog b/dev-python/nose/ChangeLog
index b6e26da8a990..130b253ee433 100644
--- a/dev-python/nose/ChangeLog
+++ b/dev-python/nose/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/nose
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.101 2013/02/26 14:56:54 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.102 2013/03/02 12:40:32 idella4 Exp $
+
+ 02 Mar 2013; Ian Delaney <idella4@gentoo.org>
+ +files/nose-1.2.1-skiptest.patch, nose-1.1.2-r1.ebuild, nose-1.2.1.ebuild,
+ nose-1.2.1_p2012.ebuild:
+ Added skiptest.patch for 1.2.1 versions skipping tests set to fail, wrt Bug
+ #455104
26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> nose-1.1.2-r1.ebuild:
Stable for s390, wrt bug #455724
diff --git a/dev-python/nose/files/nose-1.2.1-skiptest.patch b/dev-python/nose/files/nose-1.2.1-skiptest.patch
new file mode 100644
index 000000000000..b8f7a57f4da8
--- /dev/null
+++ b/dev-python/nose/files/nose-1.2.1-skiptest.patch
@@ -0,0 +1,23 @@
+Tests are set to compulsory fail, cannot be set to expectedFailure
+diff -ur nose-1.2.1.orig/functional_tests/test_program.py nose-1.2.1/functional_tests/test_program.py
+--- functional_tests/test_program.py 2011-12-14 22:01:38.000000000 +0800
++++ functional_tests/test_program.py 2013-03-02 14:50:28.628004408 +0800
+@@ -1,5 +1,8 @@
+-import os
+-import unittest
++import os, sys
++if sys.version_info[:2] == (2, 7) or hasattr(sys, 'pypy_version_info'):
++ import unittest
++else:
++ import unittest2 as unittest
+ from cStringIO import StringIO
+ from nose import SkipTest
+ from nose.core import TestProgram
+@@ -91,6 +91,7 @@
+ assert not res.errors
+ assert not res.failures
+
++ @unittest.skip("tests set to exit with compulsory fail, error")
+ def test_run_support_twist(self):
+ """Collect and run tests in functional/support/twist
+
diff --git a/dev-python/nose/nose-1.2.1.ebuild b/dev-python/nose/nose-1.2.1.ebuild
index f063cec985b8..6c68b5065ea6 100644
--- a/dev-python/nose/nose-1.2.1.ebuild
+++ b/dev-python/nose/nose-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-1.2.1.ebuild,v 1.2 2013/01/02 20:54:55 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-1.2.1.ebuild,v 1.3 2013/03/02 12:40:32 idella4 Exp $
EAPI=5
@@ -28,8 +28,10 @@ python_prepare_all() {
# Tests need to be converted, and they don't respect BUILD_DIR.
use test && DISTUTILS_IN_SOURCE_BUILD=1
- # Disable sphinx.ext.intersphinx, requires network
- epatch "${FILESDIR}/${PN}-0.11.0-disable_intersphinx.patch"
+ # Disable sphinx.ext.intersphinx, requires network, rogue test
+ epatch "${FILESDIR}/${PN}-0.11.0-disable_intersphinx.patch" \
+ "${FILESDIR}"/${P}-skiptest.patch
+
# Disable tests requiring network connection.
sed \
-e "s/test_resolve/_&/g" \
diff --git a/dev-python/nose/nose-1.2.1_p2012.ebuild b/dev-python/nose/nose-1.2.1_p2012.ebuild
index 54b1df9bee87..c1ed6d6d09b1 100644
--- a/dev-python/nose/nose-1.2.1_p2012.ebuild
+++ b/dev-python/nose/nose-1.2.1_p2012.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-1.2.1_p2012.ebuild,v 1.1 2013/01/08 18:40:41 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-1.2.1_p2012.ebuild,v 1.2 2013/03/02 12:40:32 idella4 Exp $
EAPI=5
@@ -28,8 +28,10 @@ python_prepare_all() {
# Tests need to be converted, and they don't respect BUILD_DIR.
use test && DISTUTILS_IN_SOURCE_BUILD=1
- # Disable sphinx.ext.intersphinx, requires network
- epatch "${FILESDIR}/${PN}-0.11.0-disable_intersphinx.patch"
+ # Disable sphinx.ext.intersphinx, requires network, rogue test
+ epatch "${FILESDIR}/${PN}-0.11.0-disable_intersphinx.patch" \
+ "${FILESDIR}"/${P/_p2012/}-skiptest.patch
+
# Disable tests requiring network connection.
sed \
-e "s/test_resolve/_&/g" \