summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-06-25 10:26:21 +0000
committerAli Polatel <hawking@gentoo.org>2008-06-25 10:26:21 +0000
commit3b8bfc4c84940850af969ca23c28f1e265e07e34 (patch)
tree9e84707318886b0ff8222224255034f84880c260 /dev-python/nose
parentx11-misc/shared-mime-info: add elog message to update the generated databases (diff)
downloadgentoo-2-3b8bfc4c84940850af969ca23c28f1e265e07e34.tar.gz
gentoo-2-3b8bfc4c84940850af969ca23c28f1e265e07e34.tar.bz2
gentoo-2-3b8bfc4c84940850af969ca23c28f1e265e07e34.zip
Version bump.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r1 x86_64)
Diffstat (limited to 'dev-python/nose')
-rw-r--r--dev-python/nose/ChangeLog7
-rw-r--r--dev-python/nose/nose-0.10.3.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/nose/ChangeLog b/dev-python/nose/ChangeLog
index 99020e4a4755..31691825b728 100644
--- a/dev-python/nose/ChangeLog
+++ b/dev-python/nose/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/nose
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.10 2008/01/31 16:38:56 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.11 2008/06/25 10:26:21 hawking Exp $
+
+*nose-0.10.3 (25 Jun 2008)
+
+ 25 Jun 2008; Ali Polatel <hawking@gentoo.org> +nose-0.10.3.ebuild:
+ Version bump.
*nose-0.10.1 (31 Jan 2008)
diff --git a/dev-python/nose/nose-0.10.3.ebuild b/dev-python/nose/nose-0.10.3.ebuild
new file mode 100644
index 000000000000..26c0c8e0ed2a
--- /dev/null
+++ b/dev-python/nose/nose-0.10.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-0.10.3.ebuild,v 1.1 2008/06/25 10:26:21 hawking Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
+HOMEPAGE="http://somethingaboutorange.com/mrl/projects/nose/"
+SRC_URI="http://somethingaboutorange.com/mrl/projects/nose/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/setuptools"
+DEPEND="${RDEPEND}
+ test? ( dev-python/twisted )"
+
+src_unpack() {
+ distutils_src_unpack
+
+ # Disable tests that access the network
+ epatch "${FILESDIR}/${PN}-0.10.0-tests-nonetwork.patch"
+}
+
+src_install() {
+ DOCS="AUTHORS"
+ distutils_src_install --install-data /usr/share
+
+ use doc && dohtml doc/*
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+src_test() {
+ # Create the missing empty directory, that's required for tests to pass
+ if [[ ! -e "${S}"/functional_tests/support/empty ]]; then
+ mkdir "${S}"/functional_tests/support/empty
+ fi
+ PYTHONPATH=. "${python}" setup.py test || die "test failed"
+}