summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2013-06-08 15:05:22 +0000
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2013-06-08 15:05:22 +0000
commit82c9d85e9f27febfb4f46bce4b8d50f8e8f1c485 (patch)
treece931dcd0a472e032dde4544f8552b8b3c74c444 /dev-python/munkres
parentConvert to python-single-r1. Replace dev-python/imaging with virtual/python-i... (diff)
downloadgentoo-2-82c9d85e9f27febfb4f46bce4b8d50f8e8f1c485.tar.gz
gentoo-2-82c9d85e9f27febfb4f46bce4b8d50f8e8f1c485.tar.bz2
gentoo-2-82c9d85e9f27febfb4f46bce4b8d50f8e8f1c485.zip
Update to EAPI5
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 7B087241)
Diffstat (limited to 'dev-python/munkres')
-rw-r--r--dev-python/munkres/ChangeLog10
-rw-r--r--dev-python/munkres/munkres-1.0.5.4-r2.ebuild27
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-python/munkres/ChangeLog b/dev-python/munkres/ChangeLog
index 9382f7403aa9..b01d0164770a 100644
--- a/dev-python/munkres/ChangeLog
+++ b/dev-python/munkres/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/munkres
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/munkres/ChangeLog,v 1.3 2012/05/30 12:44:32 xarthisius Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/munkres/ChangeLog,v 1.4 2013/06/08 15:05:22 sochotnicky Exp $
+
+*munkres-1.0.5.4-r2 (08 Jun 2013)
+
+ 08 Jun 2013; Stanislav Ochotnicky <sochotnicky@gentoo.org>
+ +munkres-1.0.5.4-r2.ebuild:
+ Update to EAPI5
*munkres-1.0.5.4-r1 (30 May 2012)
diff --git a/dev-python/munkres/munkres-1.0.5.4-r2.ebuild b/dev-python/munkres/munkres-1.0.5.4-r2.ebuild
new file mode 100644
index 000000000000..ab77eaff74c7
--- /dev/null
+++ b/dev-python/munkres/munkres-1.0.5.4-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/munkres/munkres-1.0.5.4-r2.ebuild,v 1.1 2013/06/08 15:05:22 sochotnicky Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module implementing munkres algorithm for the Assignment Problem"
+HOMEPAGE="http://pypi.python.org/pypi/munkres/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+python_test() {
+ "${PYTHON}" "${PN}.py" || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ dohtml -r html/
+}