summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-15 11:33:57 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-15 11:33:57 +0000
commit7eb581d24229b23a3031a2b12728432c38d45cf1 (patch)
tree4fa620867bcb19365a777cf9de3cfa56649db2e1 /dev-python/msgpack
parentVersion bump. Bug #512936 (diff)
downloadgentoo-2-7eb581d24229b23a3031a2b12728432c38d45cf1.tar.gz
gentoo-2-7eb581d24229b23a3031a2b12728432c38d45cf1.tar.bz2
gentoo-2-7eb581d24229b23a3031a2b12728432c38d45cf1.zip
drop py2.6 add pypy supp., update test phase accordingly
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/msgpack')
-rw-r--r--dev-python/msgpack/ChangeLog5
-rw-r--r--dev-python/msgpack/msgpack-0.4.2.ebuild17
2 files changed, 14 insertions, 8 deletions
diff --git a/dev-python/msgpack/ChangeLog b/dev-python/msgpack/ChangeLog
index ef2c532aaff3..cf45101c583f 100644
--- a/dev-python/msgpack/ChangeLog
+++ b/dev-python/msgpack/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/msgpack
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/msgpack/ChangeLog,v 1.18 2014/04/03 01:58:38 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/msgpack/ChangeLog,v 1.19 2014/06/15 11:33:57 idella4 Exp $
+
+ 15 Jun 2014; Ian Delaney <idella4@gentoo.org> msgpack-0.4.2.ebuild:
+ drop py2.6 add pypy supp., update test phase accordingly
*msgpack-0.4.2 (03 Apr 2014)
diff --git a/dev-python/msgpack/msgpack-0.4.2.ebuild b/dev-python/msgpack/msgpack-0.4.2.ebuild
index 85bb7f7d1454..567c1d74ee5d 100644
--- a/dev-python/msgpack/msgpack-0.4.2.ebuild
+++ b/dev-python/msgpack/msgpack-0.4.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/msgpack/msgpack-0.4.2.ebuild,v 1.1 2014/04/03 01:58:38 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/msgpack/msgpack-0.4.2.ebuild,v 1.2 2014/06/15 11:33:57 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
inherit distutils-r1
@@ -11,7 +11,7 @@ MY_PN="${PN}-python"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="MessagePack (de)serializer for Python"
-HOMEPAGE="http://msgpack.org http://pypi.python.org/pypi/msgpack-python/"
+HOMEPAGE="http://msgpack.org https://github.com/msgpack/msgpack/"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="Apache-2.0"
@@ -19,17 +19,20 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/six[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
- )
-"
+ )"
S="${WORKDIR}/${MY_P}"
+DISTUTILS_IN_SOURCE_BUILD=1
python_test() {
+ # https://github.com/msgpack/msgpack/issues/173
+ if [[ "${EPYTHON}" == pypy ]]; then
+ sed -e s':test_unpacker_hook_refcnt:_&:' -i test/test_unpack.py || die
+ fi
nosetests -P -w test || die "Tests fail with ${EPYTHON}"
}