summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2010-06-07 16:47:26 +0000
committerAndrey Grozin <grozin@gentoo.org>2010-06-07 16:47:26 +0000
commitf4b3b78742fe048acd88aa11e7be660ec923fba3 (patch)
tree876bd1aa48521bffadfed9a8c16496cb635088ed /dev-python/mpmath
parentAvoid piwik code when generating docs, thanks Chris Mayo for his patch, bug #... (diff)
downloadgentoo-2-f4b3b78742fe048acd88aa11e7be660ec923fba3.tar.gz
gentoo-2-f4b3b78742fe048acd88aa11e7be660ec923fba3.tar.bz2
gentoo-2-f4b3b78742fe048acd88aa11e7be660ec923fba3.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'dev-python/mpmath')
-rw-r--r--dev-python/mpmath/ChangeLog8
-rw-r--r--dev-python/mpmath/mpmath-0.15.ebuild (renamed from dev-python/mpmath/mpmath-0.13.ebuild)33
2 files changed, 25 insertions, 16 deletions
diff --git a/dev-python/mpmath/ChangeLog b/dev-python/mpmath/ChangeLog
index cdd9890d8330..bb3b8312c50e 100644
--- a/dev-python/mpmath/ChangeLog
+++ b/dev-python/mpmath/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/mpmath
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/ChangeLog,v 1.11 2010/02/07 20:57:23 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/ChangeLog,v 1.12 2010/06/07 16:47:26 grozin Exp $
+
+*mpmath-0.15 (07 Jun 2010)
+
+ 07 Jun 2010; Andrey Grozin <grozin@gentoo.org> -mpmath-0.13.ebuild,
+ +mpmath-0.15.ebuild:
+ Version bump
07 Feb 2010; Peter Volkov <pva@gentoo.org> mpmath-0.13.ebuild:
$HOMEPAGE: Never refer to a variable name in the string; include only raw
diff --git a/dev-python/mpmath/mpmath-0.13.ebuild b/dev-python/mpmath/mpmath-0.15.ebuild
index e928a50ec4a4..6fbcebf1e9e0 100644
--- a/dev-python/mpmath/mpmath-0.13.ebuild
+++ b/dev-python/mpmath/mpmath-0.15.ebuild
@@ -1,35 +1,43 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/mpmath-0.13.ebuild,v 1.2 2010/02/07 20:57:23 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/mpmath-0.15.ebuild,v 1.1 2010/06/07 16:47:26 grozin Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="py.test"
-EAPI=2
-NEED_PYTHON=2.4
inherit distutils
DESCRIPTION="A python library for arbitrary-precision floating-point arithmetic"
-HOMEPAGE="http://code.google.com/p/mpmath"
+HOMEPAGE="http://code.google.com/p/mpmath/ http://pypi.python.org/pypi/mpmath/"
SRC_URI="http://mpmath.googlecode.com/files/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc examples gmp test"
+IUSE="doc examples gmp"
RDEPEND="gmp? ( dev-python/gmpy )"
-DEPEND="doc? ( dev-python/sphinx )
- test? ( dev-python/py )"
+DEPEND="doc? ( dev-python/sphinx )"
+RESTRICT_PYTHON_ABIS="3.*"
+
+DOCS="CHANGES"
src_compile() {
distutils_src_compile
if use doc; then
cd doc
- "${python}" build.py
- cd ..
+ "$(PYTHON -f)" build.py
fi
}
+src_test() {
+ cd mpmath/tests
+ distutils_src_test
+}
+
src_install() {
- DOCS="CHANGES"
distutils_src_install
if use doc; then
@@ -43,8 +51,3 @@ src_install() {
doins demo/*
fi
}
-
-src_test() {
- cd mpmath/tests
- py.test || die "tests failed"
-}