summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-07-23 11:54:39 +0000
committerIan Delaney <idella4@gentoo.org>2013-07-23 11:54:39 +0000
commit01884af4013b94c28e69b24ee0162fd6096a5bb8 (patch)
tree454612d42af04b28f929bb5c44aa44462be19d90 /dev-python/mozrunner/mozrunner-5.18-r1.ebuild
parentwhitespace (diff)
downloadgentoo-2-01884af4013b94c28e69b24ee0162fd6096a5bb8.tar.gz
gentoo-2-01884af4013b94c28e69b24ee0162fd6096a5bb8.tar.bz2
gentoo-2-01884af4013b94c28e69b24ee0162fd6096a5bb8.zip
migrate -> distutils-r1, add missing rdep and correct deps, drop some old
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/mozrunner/mozrunner-5.18-r1.ebuild')
-rw-r--r--dev-python/mozrunner/mozrunner-5.18-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/mozrunner/mozrunner-5.18-r1.ebuild b/dev-python/mozrunner/mozrunner-5.18-r1.ebuild
new file mode 100644
index 000000000000..c9e0bae8b584
--- /dev/null
+++ b/dev-python/mozrunner/mozrunner-5.18-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mozrunner/mozrunner-5.18-r1.ebuild,v 1.1 2013/07/23 11:54:39 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Reliable start/stop/configuration of Mozilla Applications (Firefox, Thunderbird, etc.)"
+HOMEPAGE="http://pypi.python.org/pypi/mozrunner"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/mozinfo-0.3.3[${PYTHON_USEDEP}]
+ >=dev-python/mozprofile-0.10[${PYTHON_USEDEP}]
+ >=dev-python/mozprocess-0.10[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/mozfile[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -e 's/\(moz.*\) ==/\1 >=/' -i setup.py
+ distutils-r1_python_prepare_all
+}