summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2006-10-08 19:34:51 +0000
committerBryan Østergaard <kloeri@gentoo.org>2006-10-08 19:34:51 +0000
commit2826695c26dfc02c33687fa80714866800e2c6c4 (patch)
tree5c3a6415091febb044c6985202668a9b39cdb25c /dev-python/mod_python
parentinitial import (diff)
downloadgentoo-2-2826695c26dfc02c33687fa80714866800e2c6c4.tar.gz
gentoo-2-2826695c26dfc02c33687fa80714866800e2c6c4.tar.bz2
gentoo-2-2826695c26dfc02c33687fa80714866800e2c6c4.zip
Version bump, bug 123852.
(Portage version: 2.1.2_pre2-r6)
Diffstat (limited to 'dev-python/mod_python')
-rw-r--r--dev-python/mod_python/ChangeLog8
-rw-r--r--dev-python/mod_python/files/digest-mod_python-3.2.103
-rw-r--r--dev-python/mod_python/mod_python-3.2.10.ebuild63
3 files changed, 73 insertions, 1 deletions
diff --git a/dev-python/mod_python/ChangeLog b/dev-python/mod_python/ChangeLog
index e04c9e1cee6b..7185c4089382 100644
--- a/dev-python/mod_python/ChangeLog
+++ b/dev-python/mod_python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/mod_python
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/ChangeLog,v 1.46 2006/07/14 16:37:56 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/ChangeLog,v 1.47 2006/10/08 19:34:51 kloeri Exp $
+
+*mod_python-3.2.10 (08 Oct 2006)
+
+ 08 Oct 2006; Bryan Østergaard <kloeri@gentoo.org>
+ +mod_python-3.2.10.ebuild:
+ Version bump, bug 123852.
14 Jul 2006; Marien Zwart <marienz@gentoo.org> -files/mod_python.conf,
-mod_python-2.7.10.ebuild:
diff --git a/dev-python/mod_python/files/digest-mod_python-3.2.10 b/dev-python/mod_python/files/digest-mod_python-3.2.10
new file mode 100644
index 000000000000..6d9dfb733230
--- /dev/null
+++ b/dev-python/mod_python/files/digest-mod_python-3.2.10
@@ -0,0 +1,3 @@
+MD5 cc6439f546a6e70cfff7ca51b8c62541 mod_python-3.2.10.tgz 365768
+RMD160 2afdd0a80c815f8b9a1b33258e04ae17a12b7dbd mod_python-3.2.10.tgz 365768
+SHA256 ac404c02ee052dcfbd8e303fe9148866c561be9b9a8a12cffee25276e147f13c mod_python-3.2.10.tgz 365768
diff --git a/dev-python/mod_python/mod_python-3.2.10.ebuild b/dev-python/mod_python/mod_python-3.2.10.ebuild
new file mode 100644
index 000000000000..ba5330f47c17
--- /dev/null
+++ b/dev-python/mod_python/mod_python-3.2.10.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/mod_python-3.2.10.ebuild,v 1.1 2006/10/08 19:34:51 kloeri Exp $
+
+inherit python eutils apache-module autotools
+
+DESCRIPTION="An Apache2 DSO providing an embedded Python interpreter"
+HOMEPAGE="http://www.modpython.org/"
+SRC_URI="mirror://apache/httpd/modpython/${P}.tgz"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND="dev-lang/python"
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_DEFINE="PYTHON"
+
+DOCFILES="README NEWS CREDITS COPYRIGHT"
+
+need_apache2
+
+src_unpack() {
+ unpack ${A} || die "unpack failed"
+ cd ${S} || die "cd \$S failed"
+
+ # remove optimisations, we do that outside portage
+ sed -ie 's:--optimize 2:--no-compile:' dist/Makefile.in
+
+ # Fix compilation when using Python-2.3
+ if has_version ">=dev-lang/python-2.3"; then
+ sed -ie 's:LONG_LONG:PY_LONG_LONG:g' "${S}/src/requestobject.c"
+ fi
+
+ eautoconf
+}
+
+src_compile() {
+ econf --with-apxs=${APXS2} || die
+ emake OPT="`apxs2 -q CFLAGS` -fPIC" || die
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+
+ dohtml doc-html/*
+ insinto /usr/share/doc/${PF}/html/icons
+ doins doc-html/icons/*
+
+ apache-module_src_install
+ insinto ${APACHE2_MODULES_CONFDIR}
+ newins ${FILESDIR}/16_${PN}-r1.conf 16_${PN}.conf
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/mod_python
+ apache-module_pkg_postinst
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}