summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-05-02 10:17:45 +0000
committerIan Delaney <idella4@gentoo.org>2013-05-02 10:17:45 +0000
commit48068f70ebef5c9564b6e2636ac0e42786398032 (patch)
tree95faa567fa0106c6a940243a18c9a545ba49a57d /dev-python/mimeparse
parentsci-chemistry/molmol: Respect AR, #468178 (diff)
downloadgentoo-2-48068f70ebef5c9564b6e2636ac0e42786398032.tar.gz
gentoo-2-48068f70ebef5c9564b6e2636ac0e42786398032.tar.bz2
gentoo-2-48068f70ebef5c9564b6e2636ac0e42786398032.zip
migrate -> distutils-r1
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/mimeparse')
-rw-r--r--dev-python/mimeparse/ChangeLog9
-rw-r--r--dev-python/mimeparse/mimeparse-0.1.3-r1.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-python/mimeparse/ChangeLog b/dev-python/mimeparse/ChangeLog
index 6ac5c33c0d59..082cb61de127 100644
--- a/dev-python/mimeparse/ChangeLog
+++ b/dev-python/mimeparse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/mimeparse
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mimeparse/ChangeLog,v 1.3 2012/11/13 10:32:25 idella4 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mimeparse/ChangeLog,v 1.4 2013/05/02 10:17:45 idella4 Exp $
+
+*mimeparse-0.1.3-r1 (02 May 2013)
+
+ 02 May 2013; Ian Delaney <idella4@gentoo.org> +mimeparse-0.1.3-r1.ebuild:
+ migrate -> distutils-r1
14 Nov 2012; Ian Delaney <idella4@gentoo.org> metadata.xml:
Updating maintainer, metadata.xml
diff --git a/dev-python/mimeparse/mimeparse-0.1.3-r1.ebuild b/dev-python/mimeparse/mimeparse-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..c5955ed74e19
--- /dev/null
+++ b/dev-python/mimeparse/mimeparse-0.1.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mimeparse/mimeparse-0.1.3-r1.ebuild,v 1.1 2013/05/02 10:17:45 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_2,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Basic functions for handling mime-types in python"
+HOMEPAGE="http://code.google.com/p/mimeparse"
+SRC_URI="http://mimeparse.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/simplejson[$(python_gen_usedep python2_5)] )"
+
+# tests fail for python3
+python_test() {
+ if [[ "${EPYTHON}" == python3* ]]; then
+ einfo "mimeparse_test.py not written for python3"
+ else
+ "${PYTHON}" mimeparse_test.py || die
+ fi
+}