summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-01-15 09:57:46 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-01-15 09:57:46 +0000
commitcdd435535e0aa18e445501ac94e2ed83616e6b28 (patch)
tree6053613de4f57dd9f78c69146ba1e3f750693c13 /dev-python/matplotlib
parentRevbump so users get the fix on the init script, bug #254995, thanks to Matt ... (diff)
downloadgentoo-2-cdd435535e0aa18e445501ac94e2ed83616e6b28.tar.gz
gentoo-2-cdd435535e0aa18e445501ac94e2ed83616e6b28.tar.bz2
gentoo-2-cdd435535e0aa18e445501ac94e2ed83616e6b28.zip
Reorganized dependencies. Added enthought traits support, removed bundled pyparsing, pycxx (bug #252947) and fonts. Temporary mirror restricting since upstream has changed source (bug #252578)
(Portage version: 2.2_rc20/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/ChangeLog13
-rw-r--r--dev-python/matplotlib/matplotlib-0.98.5.2-r1.ebuild (renamed from dev-python/matplotlib/matplotlib-0.98.3.ebuild)98
-rw-r--r--dev-python/matplotlib/matplotlib-0.98.5.2.ebuild6
-rw-r--r--dev-python/matplotlib/metadata.xml5
4 files changed, 76 insertions, 46 deletions
diff --git a/dev-python/matplotlib/ChangeLog b/dev-python/matplotlib/ChangeLog
index a3ead7b249a0..de35ae152a6b 100644
--- a/dev-python/matplotlib/ChangeLog
+++ b/dev-python/matplotlib/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-python/matplotlib
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.55 2008/12/23 11:41:41 bicatali Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.56 2009/01/15 09:57:46 bicatali Exp $
+
+*matplotlib-0.98.5.2-r1 (15 Jan 2009)
+
+ 15 Jan 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ -matplotlib-0.98.3.ebuild, matplotlib-0.98.5.2.ebuild,
+ +matplotlib-0.98.5.2-r1.ebuild:
+ Reorganized dependencies. Added enthought traits support, removed bundled
+ pyparsing, pycxx (bug #252947) and fonts. Temporary mirror restricting
+ since upstream has changed source (bug #252578)
23 Dec 2008; Sébastien Fabbro <bicatali@gentoo.org>
matplotlib-0.98.5.2.ebuild:
diff --git a/dev-python/matplotlib/matplotlib-0.98.3.ebuild b/dev-python/matplotlib/matplotlib-0.98.5.2-r1.ebuild
index 720e5a7c2a3e..11209df61b05 100644
--- a/dev-python/matplotlib/matplotlib-0.98.3.ebuild
+++ b/dev-python/matplotlib/matplotlib-0.98.5.2-r1.ebuild
@@ -1,48 +1,57 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.98.3.ebuild,v 1.4 2009/01/03 04:44:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.98.5.2-r1.ebuild,v 1.1 2009/01/15 09:57:46 bicatali Exp $
WX_GTK_VER=2.8
-EAPI=1
-inherit eutils distutils wxwidgets
+EAPI=2
+inherit distutils wxwidgets
-DOC_PV=${PV}
+PDOC="users_guide_${PV}"
DESCRIPTION="Pure python plotting library with matlab like syntax"
HOMEPAGE="http://matplotlib.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- doc? ( http://matplotlib.sourceforge.net/users_guide_${DOC_PV}.pdf )"
+ doc? ( http://matplotlib.sourceforge.net/Matplotlib.pdf -> ${PDOC}.pdf )"
-IUSE="cairo doc examples excel fltk gtk latex qt3 qt4 tk wxwindows"
+IUSE="cairo doc excel examples fltk gtk latex qt3 qt4 traits tk wxwindows"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-LICENSE="PYTHON BSD stix bakoma"
+KEYWORDS="~amd64 ~x86"
+LICENSE="PYTHON BSD"
-DEPEND=">=dev-python/numpy-1.1
- >=media-libs/freetype-2
- media-libs/libpng
- dev-python/pytz
+CDEPEND=">=dev-python/numpy-1.1
dev-python/python-dateutil
+ dev-python/pytz
+ media-libs/freetype:2
+ media-libs/libpng
gtk? ( dev-python/pygtk )
+ tk? ( dev-lang/python[tk] )
wxwindows? ( dev-python/wxpython:2.8 )"
-RDEPEND="${DEPEND}
- || ( media-fonts/ttf-bitstream-vera media-fonts/dejavu )
- latex? ( virtual/latex-base
+DEPEND="${CDEPEND}
+ dev-python/pycxx
+ dev-util/pkgconfig"
+
+RDEPEND="${CDEPEND}
+ dev-python/pyparsing
+ || ( media-fonts/dejavu media-fonts/ttf-bitstream-vera )
+ cairo? ( dev-python/pycairo )
+ excel? ( dev-python/xlwt )
+ fltk? ( dev-python/pyfltk )
+ qt3? ( dev-python/PyQt )
+ qt4? ( dev-python/PyQt4 )
+ traits? ( dev-python/traits dev-python/configobj )
+ latex? (
+ virtual/latex-base
virtual/ghostscript
app-text/dvipng
- app-text/poppler )
- cairo? ( dev-python/pycairo )
- excel? ( dev-python/xlwt )
- fltk? ( dev-python/pyfltk )
- qt3? ( dev-python/PyQt )
- qt4? ( dev-python/PyQt4 )"
-
-DOCS="INTERACTIVE API_CHANGES"
+ app-text/poppler
+ media-fonts/stix-fonts
+ || ( dev-texlive/texlive-fontsrecommended
+ app-text/tetex
+ app-text/ptex ) )"
-pkg_setup() {
- use tk && distutils_python_tkinter
-}
+RESTRICT=mirror
+DOCS="INTERACTIVE"
use_setup() {
local uword="${2}"
@@ -56,9 +65,7 @@ use_setup() {
fi
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
# create setup.cfg (see setup.cfg.template for any changes)
cat > setup.cfg <<-EOF
[provide_packages]
@@ -76,14 +83,15 @@ src_unpack() {
$(use_setup cairo)
EOF
- # sed to avoid checks needing a X display
+ # avoid checks needing a X display
sed -i \
-e "s/check_for_gtk()/$(use gtk && echo True || echo False)/" \
-e "s/check_for_tk()/$(use tk && echo True || echo False)/" \
setup.py || die "sed setup.py failed"
- # respect FHS: put mpl-data in /usr/share/matplotlib
- # and config files in /etc/matplotlib
+ # respect FHS:
+ # - mpl-data in /usr/share/matplotlib
+ # - config files in /etc/matplotlib
sed -i \
-e "/'mpl-data\/matplotlibrc',/d" \
-e "/'mpl-data\/matplotlib.conf',/d" \
@@ -98,9 +106,16 @@ src_unpack() {
lib/matplotlib/{__init__,config/cutils}.py \
|| die "sed init for FHS failed"
- # remove vera fonts (they are now a dependency)
- cd lib/matplotlib/mpl-data
- rm -f ttf/Vera*.ttf ttf/*.TXT ttf/local.conf pdfcorefonts/readme.txt
+ # remove internal copies of fonts, pycxx, pyparsing
+ rm -rf \
+ CXX \
+ lib/matplotlib/mpl-data/fonts \
+ lib/matplotlib/pyparsing.py \
+ || die "removed internal copies failed"
+ ln -s /usr/share/python*/CXX . || die
+ sed -i \
+ -e 's/matplotlib.pyparsing/pyparsing/g' \
+ lib/matplotlib/*.py || die "sed for pyparsing failed"
}
src_install() {
@@ -110,13 +125,16 @@ src_install() {
dodir /usr/share/${PN}
mv "${D}"/usr/*/*/site-packages/${PN}/{mpl-data,backends/Matplotlib.nib} \
"${D}"/usr/share/${PN} || die "failed renaming"
-
insinto /etc/matplotlib
doins matplotlibrc matplotlib.conf \
|| die "installing config files failed"
+ # doc and examples
insinto /usr/share/doc/${PF}
- use doc && newins "${DISTDIR}"/users_guide_${DOC_PV}.pdf \
- ${P}-users-guide.pdf
- use examples && doins -r examples
+ if use doc; then
+ doins "${DISTDIR}"/${PDOC}.pdf || die
+ fi
+ if use examples; then
+ doins -r examples || die
+ fi
}
diff --git a/dev-python/matplotlib/matplotlib-0.98.5.2.ebuild b/dev-python/matplotlib/matplotlib-0.98.5.2.ebuild
index e0d2a5fe830e..8609d393e077 100644
--- a/dev-python/matplotlib/matplotlib-0.98.5.2.ebuild
+++ b/dev-python/matplotlib/matplotlib-0.98.5.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.98.5.2.ebuild,v 1.2 2008/12/23 11:41:41 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.98.5.2.ebuild,v 1.3 2009/01/15 09:57:46 bicatali Exp $
WX_GTK_VER=2.8
EAPI=2
@@ -39,7 +39,7 @@ RDEPEND="${DEPEND}
qt4? ( dev-python/PyQt4 )"
DOCS="INTERACTIVE"
-
+RESTRICT="mirror"
use_setup() {
local uword="${2}"
[ -z "${2}" ] && uword="${1}"
diff --git a/dev-python/matplotlib/metadata.xml b/dev-python/matplotlib/metadata.xml
index 311a2fbcf2cc..90e550e8de62 100644
--- a/dev-python/matplotlib/metadata.xml
+++ b/dev-python/matplotlib/metadata.xml
@@ -9,6 +9,9 @@
variety of backends and hard copy formats for almost ready publication plots.
</longdescription>
<use>
- <flag name='excel'>Pull <pkg>dev-python/xlwt</pkg> for the exceltools toolkit</flag>
+ <flag name='excel'>Pull <pkg>dev-python/xlwt</pkg> for the
+ exceltools toolkit</flag>
+ <flag name='traits'>Pull <pkg>dev-python/traits</pkg> for the
+ experimental enthought traits support</flag>
</use>
</pkgmetadata>