summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2006-07-17 15:59:42 +0000
committerAlastair Tse <liquidx@gentoo.org>2006-07-17 15:59:42 +0000
commitca24128cd1a271c22ad5413119e02cc25aea8b72 (patch)
treea636241c1c8cc668fa2e1b291eab23cacda6ab9b /dev-python/matplotlib
parentMarked ~ppc-macos (bug #139735) (diff)
downloadgentoo-2-ca24128cd1a271c22ad5413119e02cc25aea8b72.tar.gz
gentoo-2-ca24128cd1a271c22ad5413119e02cc25aea8b72.tar.bz2
gentoo-2-ca24128cd1a271c22ad5413119e02cc25aea8b72.zip
version bump. fix broken compiling of c++ modules.
(Portage version: 2.1-r1)
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/ChangeLog9
-rw-r--r--dev-python/matplotlib/files/digest-matplotlib-0.87.43
-rw-r--r--dev-python/matplotlib/files/matplotlib-0.87.4-fix-bad-win32-detect.patch12
-rw-r--r--dev-python/matplotlib/matplotlib-0.87.4.ebuild60
4 files changed, 83 insertions, 1 deletions
diff --git a/dev-python/matplotlib/ChangeLog b/dev-python/matplotlib/ChangeLog
index 0b291c668117..bfca068da3b8 100644
--- a/dev-python/matplotlib/ChangeLog
+++ b/dev-python/matplotlib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/matplotlib
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.22 2006/07/16 13:39:08 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.23 2006/07/17 15:59:42 liquidx Exp $
+
+*matplotlib-0.87.4 (17 Jul 2006)
+
+ 17 Jul 2006; Alastair Tse <liquidx@gentoo.org>
+ +files/matplotlib-0.87.4-fix-bad-win32-detect.patch,
+ -matplotlib-0.87.3.ebuild, +matplotlib-0.87.4.ebuild:
+ version bump. fix broken compiling of c++ modules.
*matplotlib-0.87.3 (16 Jul 2006)
diff --git a/dev-python/matplotlib/files/digest-matplotlib-0.87.4 b/dev-python/matplotlib/files/digest-matplotlib-0.87.4
new file mode 100644
index 000000000000..5d10ebe7218b
--- /dev/null
+++ b/dev-python/matplotlib/files/digest-matplotlib-0.87.4
@@ -0,0 +1,3 @@
+MD5 b8ef6ee4b4a7267d94980b4678f950ea matplotlib-0.87.4.tar.gz 2985247
+RMD160 21b2a02c02a809438c2a45835e4e5a76576884b9 matplotlib-0.87.4.tar.gz 2985247
+SHA256 c30f68e90170acd3a2f5f7cfa188cdc5ef81880eb82c20b915a549e4b2ad2b9a matplotlib-0.87.4.tar.gz 2985247
diff --git a/dev-python/matplotlib/files/matplotlib-0.87.4-fix-bad-win32-detect.patch b/dev-python/matplotlib/files/matplotlib-0.87.4-fix-bad-win32-detect.patch
new file mode 100644
index 000000000000..38958567bf23
--- /dev/null
+++ b/dev-python/matplotlib/files/matplotlib-0.87.4-fix-bad-win32-detect.patch
@@ -0,0 +1,12 @@
+--- setupext.py~ 2006-07-10 18:55:59.000000000 +0100
++++ setupext.py 2006-07-17 16:47:19.000000000 +0100
+@@ -116,7 +116,8 @@
+ return 'mingw32'
+ return 'msvc'
+ win32_compiler = get_win32_compiler()
+-if win32_compiler == 'msvc':
++
++if sys.platform == 'win32' and win32_compiler == 'msvc':
+ std_libs = []
+ else:
+ std_libs = ['stdc++', 'm']
diff --git a/dev-python/matplotlib/matplotlib-0.87.4.ebuild b/dev-python/matplotlib/matplotlib-0.87.4.ebuild
new file mode 100644
index 000000000000..bc47b00461d1
--- /dev/null
+++ b/dev-python/matplotlib/matplotlib-0.87.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.87.4.ebuild,v 1.1 2006/07/17 15:59:42 liquidx Exp $
+
+inherit distutils python
+
+DESCRIPTION="matplotlib is a pure python plotting library designed to bring publication quality plotting to python with a syntax familiar to matlab users."
+HOMEPAGE="http://matplotlib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+IUSE="doc gtk tcltk"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="PYTHON"
+
+DEPEND="virtual/python
+ || (
+ >=dev-python/numeric-23
+ dev-python/numarray
+ dev-python/numpy
+ )
+ >=media-libs/freetype-2.1.7
+ media-libs/libpng
+ sys-libs/zlib
+ gtk? ( >=dev-python/pygtk-2.2 )
+ dev-python/pytz
+ dev-python/python-dateutil"
+
+
+pkg_setup() {
+ if use tcltk; then
+ python_tkinter_exists
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # disable autodetection, rely on USE instead
+ epatch "${FILESDIR}/${PN}-0.86.2-no-autodetect.patch"
+ sed -i \
+ -e "/^BUILD_GTK/s/'auto'/$(use gtk && echo 1 || echo 0)/" \
+ -e "/^BUILD_WX/s/'auto'/0/" \
+ -e "/^BUILD_TK/s/'auto'/$(use tcltk && echo 1 || echo 0)/" \
+ setup.py
+
+ epatch ${FILESDIR}/${PN}-0.87.4-fix-bad-win32-detect.patch
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.py examples/README
+ insinto /usr/share/doc/${PF}/examples/data
+ doins examples/data/*.dat
+ fi
+}