summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-05-24 08:03:30 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-05-24 08:03:30 +0000
commit28714ab3c4e3585d90a81394accaa93bc277b179 (patch)
tree3b6c8710a55d7a9696ec28ca919984abcaa7c82d /dev-python/matplotlib
parentVersion bump. Remove old patches. Fixes bug #222139. (diff)
downloadgentoo-2-28714ab3c4e3585d90a81394accaa93bc277b179.tar.gz
gentoo-2-28714ab3c4e3585d90a81394accaa93bc277b179.tar.bz2
gentoo-2-28714ab3c4e3585d90a81394accaa93bc277b179.zip
Added patch for gcc-4.3
(Portage version: 2.1.5.2)
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/ChangeLog6
-rw-r--r--dev-python/matplotlib/files/matplotlib-0.91.2-gcc43.patch10
-rw-r--r--dev-python/matplotlib/matplotlib-0.91.2.ebuild5
3 files changed, 18 insertions, 3 deletions
diff --git a/dev-python/matplotlib/ChangeLog b/dev-python/matplotlib/ChangeLog
index 59f089b92044..3f37940231fb 100644
--- a/dev-python/matplotlib/ChangeLog
+++ b/dev-python/matplotlib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/matplotlib
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.46 2008/05/22 21:58:12 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.47 2008/05/24 08:03:30 bicatali Exp $
+
+ 24 May 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/matplotlib-0.91.2-gcc43.patch, matplotlib-0.91.2.ebuild:
+ Added patch for gcc-4.3
22 May 2008; Sébastien Fabbro <bicatali@gentoo.org>
-matplotlib-0.90.1.ebuild, -matplotlib-0.91.1.ebuild:
diff --git a/dev-python/matplotlib/files/matplotlib-0.91.2-gcc43.patch b/dev-python/matplotlib/files/matplotlib-0.91.2-gcc43.patch
new file mode 100644
index 000000000000..042ec4c8aef0
--- /dev/null
+++ b/dev-python/matplotlib/files/matplotlib-0.91.2-gcc43.patch
@@ -0,0 +1,10 @@
+--- ttconv/pprdrv_tt2.cpp.orig 2008-05-24 08:58:22.000000000 +0100
++++ ttconv/pprdrv_tt2.cpp 2008-05-24 08:59:34.000000000 +0100
+@@ -36,6 +36,7 @@
+ #include <string.h>
+ #include <memory.h>
+ #include "pprdrv.h"
++#include <cstdio>
+ #include "truetype.h"
+ #include <algorithm>
+ #include <stack>
diff --git a/dev-python/matplotlib/matplotlib-0.91.2.ebuild b/dev-python/matplotlib/matplotlib-0.91.2.ebuild
index 52ccba171560..fbce4f462f7d 100644
--- a/dev-python/matplotlib/matplotlib-0.91.2.ebuild
+++ b/dev-python/matplotlib/matplotlib-0.91.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.91.2.ebuild,v 1.4 2008/05/10 10:34:30 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.91.2.ebuild,v 1.5 2008/05/24 08:03:30 bicatali Exp $
NEED_PYTHON=2.3
-inherit distutils
+inherit eutils distutils
DOC_PV=${PV}svn
@@ -58,6 +58,7 @@ use_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
# create setup.cfg (see setup.cfg.template for any changes)
cat > setup.cfg <<-EOF
[provide_packages]