summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-12-11 19:28:24 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-12-11 19:28:24 +0000
commit18e6def3d34a68e326a7b5096927403eb5d793dd (patch)
tree30e1b2d90b6e9aba616f82bb75d51ed033e3a001 /dev-python/matplotlib
parentVersion bump (diff)
downloadgentoo-2-18e6def3d34a68e326a7b5096927403eb5d793dd.tar.gz
gentoo-2-18e6def3d34a68e326a7b5096927403eb5d793dd.tar.bz2
gentoo-2-18e6def3d34a68e326a7b5096927403eb5d793dd.zip
Version bump
(Portage version: 2.2_rc17/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/ChangeLog8
-rw-r--r--dev-python/matplotlib/matplotlib-0.98.4.ebuild119
2 files changed, 126 insertions, 1 deletions
diff --git a/dev-python/matplotlib/ChangeLog b/dev-python/matplotlib/ChangeLog
index ea588230caa8..a5629796137c 100644
--- a/dev-python/matplotlib/ChangeLog
+++ b/dev-python/matplotlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/matplotlib
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.51 2008/10/10 08:44:05 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.52 2008/12/11 19:28:24 bicatali Exp $
+
+*matplotlib-0.98.4 (11 Dec 2008)
+
+ 11 Dec 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +matplotlib-0.98.4.ebuild:
+ Version bump
10 Oct 2008; Sébastien Fabbro <bicatali@gentoo.org>
matplotlib-0.91.2.ebuild, matplotlib-0.91.4.ebuild,
diff --git a/dev-python/matplotlib/matplotlib-0.98.4.ebuild b/dev-python/matplotlib/matplotlib-0.98.4.ebuild
new file mode 100644
index 000000000000..d1596c1dee6f
--- /dev/null
+++ b/dev-python/matplotlib/matplotlib-0.98.4.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.98.4.ebuild,v 1.1 2008/12/11 19:28:24 bicatali Exp $
+
+WX_GTK_VER=2.8
+EAPI=2
+inherit eutils distutils wxwidgets
+
+PDOC="users_guide_${PV}"
+
+DESCRIPTION="Pure python plotting library with matlab like syntax"
+HOMEPAGE="http://matplotlib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ doc? ( http://matplotlib.sourceforge.net/Matplotlib.pdf -> ${PDOC}.pdf )"
+
+IUSE="cairo doc examples fltk gtk latex qt3 qt4 tk wxwindows"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="PYTHON BSD stix bakoma"
+
+DEPEND=">=dev-python/numpy-1.1
+ >=media-libs/freetype-2
+ media-libs/libpng
+ dev-python/pytz
+ dev-python/python-dateutil
+ gtk? ( dev-python/pygtk )
+ tk? ( dev-lang/python[tk] )
+ wxwindows? ( dev-python/wxpython:2.8 )"
+
+RDEPEND="${DEPEND}
+ || ( media-fonts/ttf-bitstream-vera media-fonts/dejavu )
+ latex? ( virtual/latex-base
+ virtual/ghostscript
+ app-text/dvipng
+ app-text/poppler )
+ cairo? ( dev-python/pycairo )
+ fltk? ( dev-python/pyfltk )
+ qt3? ( dev-python/PyQt )
+ qt4? ( dev-python/PyQt4 )"
+
+DOCS="INTERACTIVE"
+
+use_setup() {
+ local uword="${2}"
+ [ -z "${2}" ] && uword="${1}"
+ if use ${1}; then
+ echo "${uword} = True"
+ echo "${uword}agg = True"
+ else
+ echo "${uword} = False"
+ echo "${uword}agg = False"
+ fi
+}
+
+src_prepare() {
+ # create setup.cfg (see setup.cfg.template for any changes)
+ cat > setup.cfg <<-EOF
+ [provide_packages]
+ pytz = False
+ dateutil = False
+ configobj = False
+ enthought.traits = False
+ [gui_support]
+ $(use_setup gtk)
+ $(use_setup tk)
+ $(use_setup wxwindows wx)
+ $(use_setup qt3 qt)
+ $(use_setup qt4)
+ $(use_setup fltk)
+ $(use_setup cairo)
+ EOF
+
+ # sed to avoid checks needing a X display
+ sed -i \
+ -e "s/check_for_gtk()/$(use gtk && echo True || echo False)/" \
+ -e "s/check_for_tk()/$(use tk && echo True || echo False)/" \
+ setup.py || die "sed setup.py failed"
+
+ # respect FHS: put mpl-data in /usr/share/matplotlib
+ # and config files in /etc/matplotlib
+ sed -i \
+ -e "/'mpl-data\/matplotlibrc',/d" \
+ -e "/'mpl-data\/matplotlib.conf',/d" \
+ -e "s:'lib/matplotlib/mpl-data/matplotlibrc':'matplotlibrc':" \
+ -e "s:'lib/matplotlib/mpl-data/matplotlib.conf':'matplotlib.conf':" \
+ setup.py \
+ || die "sed setup.py for FHS failed"
+
+ sed -i \
+ -e "s:path = get_data_path():path = '/etc/matplotlib':" \
+ -e "s:os.path.dirname(__file__):'/usr/share/${PN}':g" \
+ lib/matplotlib/{__init__,config/cutils}.py \
+ || die "sed init for FHS failed"
+
+ # remove vera fonts (they are now a dependency)
+ cd lib/matplotlib/mpl-data
+ rm -f ttf/Vera*.ttf ttf/*.TXT ttf/local.conf pdfcorefonts/readme.txt
+}
+
+src_install() {
+ distutils_src_install
+
+ # respect FHS
+ dodir /usr/share/${PN}
+ mv "${D}"/usr/*/*/site-packages/${PN}/{mpl-data,backends/Matplotlib.nib} \
+ "${D}"/usr/share/${PN} || die "failed renaming"
+
+ insinto /etc/matplotlib
+ doins matplotlibrc matplotlib.conf \
+ || die "installing config files failed"
+
+ insinto /usr/share/doc/${PF}
+ if use doc; then
+ doins "${DISTDIR}"/${PDOC}.pdf || die
+ fi
+ if use examples; then
+ doins -r examples || die
+ fi
+}