summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-01-07 20:36:32 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-01-07 20:36:32 +0000
commit798409f49b06a27ef47386828d13ceed7ad1781d (patch)
tree78c3f5ce1b9a9710effe271fe593528ec72f7cad /dev-python/lp_solve/lp_solve-5.5.2.0.ebuild
parentAdded sys-kernel/rsbac-sources to the list of providers (diff)
downloadgentoo-2-798409f49b06a27ef47386828d13ceed7ad1781d.tar.gz
gentoo-2-798409f49b06a27ef47386828d13ceed7ad1781d.tar.bz2
gentoo-2-798409f49b06a27ef47386828d13ceed7ad1781d.zip
Initial import to the main tree
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/lp_solve/lp_solve-5.5.2.0.ebuild')
-rw-r--r--dev-python/lp_solve/lp_solve-5.5.2.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/lp_solve/lp_solve-5.5.2.0.ebuild b/dev-python/lp_solve/lp_solve-5.5.2.0.ebuild
new file mode 100644
index 000000000000..895aad7aac03
--- /dev/null
+++ b/dev-python/lp_solve/lp_solve-5.5.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lp_solve/lp_solve-5.5.2.0.ebuild,v 1.1 2012/01/07 20:36:32 bicatali Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="2.4 3*"
+
+inherit distutils eutils
+
+DESCRIPTION="Python wrappers for lpsolve"
+HOMEPAGE="http://lpsolve.sourceforge.net/5.5/Python.htm"
+SRC_URI="mirror://sourceforge/lpsolve/${PN}_${PV}_Python_source.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-python/numpy
+ sci-mathematics/lpsolve"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}/${PN}_5.5/extra/Python/"
+
+src_prepare(){
+ epatch "${FILESDIR}"/${P}-setup.patch
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" \
+ "$(PYTHON)" lpdemo.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ dodoc changes
+ use doc && dohtml Python.htm
+ insinto /usr/share/doc/${PF}/examples
+ use examples && doins ex*py
+}