summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-25 16:02:24 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-25 16:02:24 +0000
commitd6d6414638c756005520a3b3237dd2f28bd2375d (patch)
tree4a30d4e6befdd2416a99b86264cb6ecc31487b2a /dev-python/logilab-constraint
parentLICENSE is GPL-3. (diff)
downloadgentoo-2-d6d6414638c756005520a3b3237dd2f28bd2375d.tar.gz
gentoo-2-d6d6414638c756005520a3b3237dd2f28bd2375d.tar.bz2
gentoo-2-d6d6414638c756005520a3b3237dd2f28bd2375d.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 14155-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/logilab-constraint')
-rw-r--r--dev-python/logilab-constraint/ChangeLog6
-rw-r--r--dev-python/logilab-constraint/logilab-constraint-0.4.0.ebuild18
2 files changed, 16 insertions, 8 deletions
diff --git a/dev-python/logilab-constraint/ChangeLog b/dev-python/logilab-constraint/ChangeLog
index 4fbb6ccd9190..29a8c8a63d2b 100644
--- a/dev-python/logilab-constraint/ChangeLog
+++ b/dev-python/logilab-constraint/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/logilab-constraint
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-constraint/ChangeLog,v 1.2 2009/05/27 15:15:28 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-constraint/ChangeLog,v 1.3 2009/08/25 16:02:24 arfrever Exp $
+
+ 25 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ logilab-constraint-0.4.0.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
27 May 2009; Ferris McCormick <fmccor@gentoo.org>
logilab-constraint-0.4.0.ebuild:
diff --git a/dev-python/logilab-constraint/logilab-constraint-0.4.0.ebuild b/dev-python/logilab-constraint/logilab-constraint-0.4.0.ebuild
index e47203c2f2b3..0477fba53a86 100644
--- a/dev-python/logilab-constraint/logilab-constraint-0.4.0.ebuild
+++ b/dev-python/logilab-constraint/logilab-constraint-0.4.0.ebuild
@@ -1,6 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-constraint/logilab-constraint-0.4.0.ebuild,v 1.3 2009/05/27 15:15:28 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-constraint/logilab-constraint-0.4.0.ebuild,v 1.4 2009/08/25 16:02:24 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
@@ -14,18 +17,19 @@ SLOT="0"
KEYWORDS="~amd64 ~sparc ~x86"
IUSE="doc"
-DOCS="doc/CONTRIBUTORS"
-PYTHON_MODNAME="logilab/constraint"
-
DEPEND=""
RDEPEND=">=dev-python/logilab-common-0.12.0"
-#S="${WORKDIR}/${MY_P}"
+RESTRICT_PYTHON_ABIS="3*"
+
+PYTHON_MODNAME="logilab/constraint"
+
+DOCS="doc/CONTRIBUTORS"
src_install() {
distutils_src_install
- # avoid conflict with dev-python/logilab-common:
+ # Avoid conflict with dev-python/logilab-common.
rm -f "${D}"usr/$(get_libdir)/python*/site-packages/logilab/__init__.py
if use doc; then
@@ -37,7 +41,7 @@ src_install() {
pkg_postinst() {
distutils_pkg_postinst
- if use x86 && ! has_version dev-python/psyco ; then
+ if use x86 && ! has_version dev-python/psyco; then
einfo ""
einfo "Although it is not required, you should consider installing"
einfo "\"dev-python/psyco\". It can speed up this module a lot."