summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-24 21:48:43 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-24 21:48:43 +0000
commit2dd55040e3c348c5cad07a79f905368b81743083 (patch)
tree8c6d2c370befed3bfce8e86c2559135a9058a5d3 /dev-python/logilab-common
parentversion bump (bug #204954) (diff)
downloadgentoo-2-2dd55040e3c348c5cad07a79f905368b81743083.tar.gz
gentoo-2-2dd55040e3c348c5cad07a79f905368b81743083.tar.bz2
gentoo-2-2dd55040e3c348c5cad07a79f905368b81743083.zip
Version bump. Don't check FEATURES (bug #278955).
(Portage version: 13850-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/logilab-common')
-rw-r--r--dev-python/logilab-common/ChangeLog8
-rw-r--r--dev-python/logilab-common/logilab-common-0.43.0.ebuild78
2 files changed, 85 insertions, 1 deletions
diff --git a/dev-python/logilab-common/ChangeLog b/dev-python/logilab-common/ChangeLog
index c6906000345d..efa3b90bbef8 100644
--- a/dev-python/logilab-common/ChangeLog
+++ b/dev-python/logilab-common/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/logilab-common
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/ChangeLog,v 1.42 2009/06/04 13:01:39 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/ChangeLog,v 1.43 2009/07/24 21:48:43 arfrever Exp $
+
+*logilab-common-0.43.0 (24 Jul 2009)
+
+ 24 Jul 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +logilab-common-0.43.0.ebuild:
+ Version bump. Don't check FEATURES (bug #278955).
*logilab-common-0.41.0 (04 Jun 2009)
diff --git a/dev-python/logilab-common/logilab-common-0.43.0.ebuild b/dev-python/logilab-common/logilab-common-0.43.0.ebuild
new file mode 100644
index 000000000000..f9109db61be4
--- /dev/null
+++ b/dev-python/logilab-common/logilab-common-0.43.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.43.0.ebuild,v 1.1 2009/07/24 21:48:43 arfrever Exp $
+
+EAPI="2"
+
+inherit distutils eutils python
+
+DESCRIPTION="useful miscellaneous modules used by Logilab projects"
+HOMEPAGE="http://www.logilab.org/projects/common/"
+SRC_URI="ftp://ftp.logilab.org/pub/common/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-python/egenix-mx-base )"
+RDEPEND=""
+
+PYTHON_MODNAME="logilab"
+# Extra documentation (html/pdf) needs some love
+
+src_prepare() {
+ distutils_src_prepare
+
+ epatch "${FILESDIR}/${PN}-0.41.0-remove-broken-tests.patch"
+}
+
+src_test() {
+ python_version
+
+ # Install temporarily.
+ local tpath="${T}/test"
+ local lpath="${tpath}/lib/python"
+
+ # setuptools would fail if the directory doesn't exist.
+ mkdir -p "${lpath}" || die
+
+ # We also have to add ${lpath} to PYTHONPATH else the installation would
+ # fail.
+ PYTHONPATH="${lpath}" ${python} setup.py install --home="${tpath}" || \
+ die "test copy failed"
+
+ # Get a rid of precompiled files to ensure we run our _modified_ tests
+ find ${lpath} -type f -name '*.pyc' -exec rm {} ';'
+
+ # Remove a botched tests.
+ # To support test w/o setuptools.
+ if [[ -d "${lpath}/${PN/-//}" ]]; then
+ pushd "${lpath}/${PN/-//}" >/dev/null || die
+ else
+ pushd "${lpath}/${P/-/_}-py${PYVER}.egg/${PN/-//}" >/dev/null || die
+ fi
+
+ # Bug 223079
+ if [[ "${EUID}" -eq 0 ]]; then
+ rm test/unittest_fileutils.py || die
+ fi
+
+ popd >/dev/null || die
+
+ # It picks up the tests relative to the current dir, so cd in. Do
+ # not cd in too far though (to logilab/common for example) or some
+ # relative/absolute module location tests fail.
+ pushd "${lpath}" >/dev/null || die
+ PYTHONPATH="${lpath}" ${python} "${tpath}/bin/pytest" -v || die "tests failed"
+ popd >/dev/null || die
+}
+
+src_install() {
+ distutils_src_install
+
+ doman doc/pytest.1 || die "doman failed"
+
+ # Remove unittests since they're just needed during build-time
+ rm -rf "${D}/$(python_get_sitedir)/${PN/-//}/test" || die
+}