summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-08-13 00:06:30 +0000
committerIan Delaney <idella4@gentoo.org>2014-08-13 00:06:30 +0000
commit2f07de8ec9e0b998d776668b0d2089350b434820 (patch)
treef3ac234d655b2ac2cabd742a9cabb85bd5f757ee /dev-python/llvmpy
parentVersion bump, remove old, effectively fixes bug 458448. (diff)
downloadgentoo-2-2f07de8ec9e0b998d776668b0d2089350b434820.tar.gz
gentoo-2-2f07de8ec9e0b998d776668b0d2089350b434820.tar.bz2
gentoo-2-2f07de8ec9e0b998d776668b0d2089350b434820.zip
bump; add pypy support, fix fix to qa build issue, thanks to Arfrever for the fix
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/llvmpy')
-rw-r--r--dev-python/llvmpy/ChangeLog8
-rw-r--r--dev-python/llvmpy/llvmpy-0.12.7.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-python/llvmpy/ChangeLog b/dev-python/llvmpy/ChangeLog
index 494bd1969e5a..48b068684918 100644
--- a/dev-python/llvmpy/ChangeLog
+++ b/dev-python/llvmpy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/llvmpy
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/llvmpy/ChangeLog,v 1.7 2014/06/16 08:58:07 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/llvmpy/ChangeLog,v 1.8 2014/08/13 00:06:30 idella4 Exp $
+
+*llvmpy-0.12.7 (12 Aug 2014)
+
+ 12 Aug 2014; Ian Delaney <idella4@gentoo.org> +llvmpy-0.12.7.ebuild:
+ bump; add pypy support, fix fix to qa build issue, thanks to Arfrever for the
+ fix
*llvmpy-0.12.6 (16 Jun 2014)
diff --git a/dev-python/llvmpy/llvmpy-0.12.7.ebuild b/dev-python/llvmpy/llvmpy-0.12.7.ebuild
new file mode 100644
index 000000000000..f2c97cec65c3
--- /dev/null
+++ b/dev-python/llvmpy/llvmpy-0.12.7.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/llvmpy/llvmpy-0.12.7.ebuild,v 1.1 2014/08/13 00:06:30 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper around the llvm C++ library"
+HOMEPAGE="http://llvmpy.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+# fails with llvm-3.4
+RDEPEND="=sys-devel/llvm-3.3*:=[multitarget]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+# Usual; req'd for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+PATCHES=( "${FILESDIR}"/${PN}-0.12.2-return-type.patch )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_compile() {
+ if ! python_is_python3; then
+ local CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
+ export CXXFLAGS
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib* || die
+ ${PYTHON} -c "import llvm; llvm.test()" || die
+}
+
+python_install() {
+ if ! python_is_python3; then
+ local CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
+ export CXXFLAGS
+ fi
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html )
+ distutils-r1_python_install_all
+}