summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-05-26 17:21:39 +0000
committerMichał Górny <mgorny@gentoo.org>2014-05-26 17:21:39 +0000
commit6dac2e12607009cd1c95c2ac958bdbef6b01a277 (patch)
tree79c7e48e35b53fb42b73d572960467664cf0e3e8 /dev-python/libwnck-python
parentConvert gnome-python-common.eclass to use python-r1, and clean it up a lot. (diff)
downloadgentoo-2-6dac2e12607009cd1c95c2ac958bdbef6b01a277.tar.gz
gentoo-2-6dac2e12607009cd1c95c2ac958bdbef6b01a277.tar.bz2
gentoo-2-6dac2e12607009cd1c95c2ac958bdbef6b01a277.zip
Convert to gnome-python-common-r1.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/libwnck-python')
-rw-r--r--dev-python/libwnck-python/ChangeLog11
-rw-r--r--dev-python/libwnck-python/libwnck-python-2.32.0-r1.ebuild29
2 files changed, 37 insertions, 3 deletions
diff --git a/dev-python/libwnck-python/ChangeLog b/dev-python/libwnck-python/ChangeLog
index 41fc9df35328..a3429ce013ee 100644
--- a/dev-python/libwnck-python/ChangeLog
+++ b/dev-python/libwnck-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/libwnck-python
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/libwnck-python/ChangeLog,v 1.51 2011/03/23 20:24:48 eva Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libwnck-python/ChangeLog,v 1.52 2014/05/26 17:21:39 mgorny Exp $
+
+*libwnck-python-2.32.0-r1 (26 May 2014)
+
+ 26 May 2014; Michał Górny <mgorny@gentoo.org>
+ +libwnck-python-2.32.0-r1.ebuild:
+ Convert to gnome-python-common-r1.
23 Mar 2011; Gilles Dartiguelongue <eva@gentoo.org>
-libwnck-python-2.30.2-r1.ebuild:
@@ -211,4 +217,3 @@
+libwnck-python-2.22.0.ebuild:
Initial import of split gnome-python-desktop. This package installs
bindings for the libwnck library.
-
diff --git a/dev-python/libwnck-python/libwnck-python-2.32.0-r1.ebuild b/dev-python/libwnck-python/libwnck-python-2.32.0-r1.ebuild
new file mode 100644
index 000000000000..43a082bc3ebe
--- /dev/null
+++ b/dev-python/libwnck-python/libwnck-python-2.32.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libwnck-python/libwnck-python-2.32.0-r1.ebuild,v 1.1 2014/05/26 17:21:39 mgorny Exp $
+
+EAPI="5"
+
+GNOME_ORG_MODULE="gnome-python-desktop"
+G_PY_BINDINGS="wnck"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome-python-common-r1 eutils
+
+DESCRIPTION="Python bindings for the libwnck library"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+RDEPEND=">=x11-libs/libwnck-2.19.3:1
+ !<dev-python/gnome-python-desktop-2.22.0-r10"
+DEPEND="${RDEPEND}"
+
+EXAMPLES=( examples/wnck_example.py )
+
+src_prepare() {
+ # Fix three enum items that should be flags, upstream bug #616306
+ epatch "${FILESDIR}/${PN}-2.30.2-flagsfix.patch"
+ gnome-python-common-r1_src_prepare
+}