summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-08-27 00:50:36 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-08-27 00:50:36 +0000
commit98b86ac4ca8b74cc8916769f0d4ab83951f47c70 (patch)
tree0f3ce3fd1236cb1c37787269c92314afd49f4731 /dev-python/libnatpmp/libnatpmp-20120821.ebuild
parentVersion bump (diff)
downloadgentoo-2-98b86ac4ca8b74cc8916769f0d4ab83951f47c70.tar.gz
gentoo-2-98b86ac4ca8b74cc8916769f0d4ab83951f47c70.tar.bz2
gentoo-2-98b86ac4ca8b74cc8916769f0d4ab83951f47c70.zip
Version bump
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/libnatpmp/libnatpmp-20120821.ebuild')
-rw-r--r--dev-python/libnatpmp/libnatpmp-20120821.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/libnatpmp/libnatpmp-20120821.ebuild b/dev-python/libnatpmp/libnatpmp-20120821.ebuild
new file mode 100644
index 000000000000..277784ef41c9
--- /dev/null
+++ b/dev-python/libnatpmp/libnatpmp-20120821.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libnatpmp/libnatpmp-20120821.ebuild,v 1.1 2012/08/27 00:50:36 blueness Exp $
+
+EAPI=3
+PYTHON_DEPEND=2
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit eutils distutils
+
+DESCRIPTION="Python module for libnatpmp, an alternative protocol to UPnP IGD."
+HOMEPAGE="http://miniupnp.free.fr/libnatpmp.html"
+SRC_URI="http://miniupnp.free.fr/files/download.php?file=${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="=net-libs/${PF}"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/link-against-system-lib.patch
+ distutils_src_prepare
+
+ #These are installed by net-libs/libnatpmp
+ rm -f Changelog.txt README || die
+}