summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-02-04 22:29:42 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-02-04 22:29:42 +0000
commit10d458c0e271962f9203d24596bed89b103d399c (patch)
tree3390e053d02a1a40ed7564b3bc1e2d1641d6ed23 /dev-python/liblarch/liblarch-2.1.0.ebuild
parenteapi=5 (diff)
downloadgentoo-2-10d458c0e271962f9203d24596bed89b103d399c.tar.gz
gentoo-2-10d458c0e271962f9203d24596bed89b103d399c.tar.bz2
gentoo-2-10d458c0e271962f9203d24596bed89b103d399c.zip
Initial ebuild, needed for new app-office/gtg.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'dev-python/liblarch/liblarch-2.1.0.ebuild')
-rw-r--r--dev-python/liblarch/liblarch-2.1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/liblarch/liblarch-2.1.0.ebuild b/dev-python/liblarch/liblarch-2.1.0.ebuild
new file mode 100644
index 000000000000..f0e4e0f1fa17
--- /dev/null
+++ b/dev-python/liblarch/liblarch-2.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/liblarch/liblarch-2.1.0.ebuild,v 1.1 2013/02/04 22:29:42 eva Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to handle directed acyclic graphs"
+HOMEPAGE="http://live.gnome.org/liblarch"
+SRC_URI="http://gtg.fritalk.com/publique/gtg.fritalk.com/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+# This is what should be run if tarball included testsuite
+#python_test() {
+# ${PYTHON} "${S}"/run-tests
+#}