summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-08-25 17:21:09 +0000
committerMike Gilbert <floppym@gentoo.org>2013-08-25 17:21:09 +0000
commit32639c038d584b909e213724ae8198d5e00da70a (patch)
tree1a5d851b79e37178253d69f14d10369fb6b1f799 /dev-python/libasyncns-python
parentAdd dev-python/apsw dep for bug #482294. (diff)
downloadgentoo-2-32639c038d584b909e213724ae8198d5e00da70a.tar.gz
gentoo-2-32639c038d584b909e213724ae8198d5e00da70a.tar.bz2
gentoo-2-32639c038d584b909e213724ae8198d5e00da70a.zip
Convert to distutils-r1.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/libasyncns-python')
-rw-r--r--dev-python/libasyncns-python/ChangeLog11
-rw-r--r--dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild (renamed from dev-python/libasyncns-python/libasyncns-python-0.7.1.ebuild)20
2 files changed, 21 insertions, 10 deletions
diff --git a/dev-python/libasyncns-python/ChangeLog b/dev-python/libasyncns-python/ChangeLog
index dd1fb2df384a..8b1ab8656290 100644
--- a/dev-python/libasyncns-python/ChangeLog
+++ b/dev-python/libasyncns-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/libasyncns-python
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/libasyncns-python/ChangeLog,v 1.3 2011/03/18 08:44:22 tomka Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libasyncns-python/ChangeLog,v 1.4 2013/08/25 17:21:09 floppym Exp $
+
+*libasyncns-python-0.7.1-r1 (25 Aug 2013)
+
+ 25 Aug 2013; Mike Gilbert <floppym@gentoo.org>
+ +libasyncns-python-0.7.1-r1.ebuild, -libasyncns-python-0.7.1.ebuild:
+ Convert to distutils-r1.
18 Mar 2011; Thomas Kahle <tomka@gentoo.org> libasyncns-python-0.7.1.ebuild:
~x86 per bug 352874
@@ -14,4 +20,3 @@
27 Mar 2009; Hanno Boeck <hanno@gentoo.org>
+libasyncns-python-0.7.1.ebuild:
Add python bindings for libasyncns.
-
diff --git a/dev-python/libasyncns-python/libasyncns-python-0.7.1.ebuild b/dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild
index 600c4fe02648..21e04e171bb5 100644
--- a/dev-python/libasyncns-python/libasyncns-python-0.7.1.ebuild
+++ b/dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/libasyncns-python/libasyncns-python-0.7.1.ebuild,v 1.4 2011/03/18 08:44:22 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild,v 1.1 2013/08/25 17:21:09 floppym Exp $
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython"
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
-inherit distutils
+inherit distutils-r1
DESCRIPTION="Python bindings for libasyncns."
HOMEPAGE="https://launchpad.net/libasyncns-python/"
@@ -20,4 +19,11 @@ IUSE=""
DEPEND=">=net-libs/libasyncns-0.4"
RDEPEND="${DEPEND}"
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+python_compile() {
+ if [[ ${EPYTHON} != python3* ]]; then
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+ distutils-r1_python_compile
+}
+
+# Tests are network-dependent