summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-03-28 06:58:26 +0000
committerAli Polatel <hawking@gentoo.org>2008-03-28 06:58:26 +0000
commitf0402340a38271226f168af5cf705e7597b6c41c (patch)
tree044b07c4e747a55dc44a72e48583b44091fc6e9c /dev-python/kiwi
parentStable for HPPA too. (diff)
downloadgentoo-2-f0402340a38271226f168af5cf705e7597b6c41c.tar.gz
gentoo-2-f0402340a38271226f168af5cf705e7597b6c41c.tar.bz2
gentoo-2-f0402340a38271226f168af5cf705e7597b6c41c.zip
Version bump.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-python/kiwi')
-rw-r--r--dev-python/kiwi/ChangeLog9
-rw-r--r--dev-python/kiwi/kiwi-1.9.21.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-python/kiwi/ChangeLog b/dev-python/kiwi/ChangeLog
index 9a566129821d..6accfd6ecab5 100644
--- a/dev-python/kiwi/ChangeLog
+++ b/dev-python/kiwi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/kiwi
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/ChangeLog,v 1.9 2007/11/11 12:56:43 lucass Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/ChangeLog,v 1.10 2008/03/28 06:58:26 hawking Exp $
+
+*kiwi-1.9.21 (28 Mar 2008)
+
+ 28 Mar 2008; Ali Polatel <hawking@gentoo.org> +kiwi-1.9.21.ebuild:
+ Version bump.
*kiwi-1.9.19 (11 Nov 2007)
diff --git a/dev-python/kiwi/kiwi-1.9.21.ebuild b/dev-python/kiwi/kiwi-1.9.21.ebuild
new file mode 100644
index 000000000000..967844032e1f
--- /dev/null
+++ b/dev-python/kiwi/kiwi-1.9.21.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/kiwi-1.9.21.ebuild,v 1.1 2008/03/28 06:58:26 hawking Exp $
+
+NEED_PYTHON=2.3
+
+inherit distutils versionator
+
+DESCRIPTION="Kiwi is a pure Python framework and set of enhanced PyGTK widgets"
+HOMEPAGE="http://www.async.com.br/projects/kiwi/"
+SRC_URI="http://download.gnome.org/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/pygtk"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s:share/doc/kiwi:share/doc/${PF}:g" \
+ setup.py || die "sed failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}